WordPress Plugin Testimonial Slider and Showcase 2.2.6 Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- No fix listed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
WordPress Plugin Testimonial Slider and Showcase 2.2.6 contains a stored cross-site scripting vulnerability that allows authenticated editors to inject malicious scripts by failing to sanitize the post_title parameter. Attackers with editor privileges can inject JavaScript payloads through the testimonial title field that execute in the browsers of users viewing the draft post, enabling cookie theft and session hijacking.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| RadiusTheme | Testimonial Slider and Showcase | 2.2.6 | — | No fix listed | CNA |
- Testimonial Slider and Showcase VendorRadiusTheme Affected 2.2.6 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-50947
- 2026-10-03 Alias added: GHSA-mffq-rxr9-jpph
References
Exploit 1
More RadiusTheme vulnerabilities
- TI-2022-02454 Classima < 2.1.11 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-08572 Team Members Showcase < 4.4.2 - Editor+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-03390 The Post Grid < 7.5.0 - Editor+ Stored XSS via Grid Creation CVSS 3.1MEDIUM 4.8
- TI-2024-01623 Testimonial Slider < 2.3.7 - Author+ Settings Update CVSS 3.1MEDIUM 4.3
- TI-2026-67962 SQL injection in RadiusTheme Radius Booking WordPress plugin CVSS 3.1CRITICAL 9.3
- TI-2026-25005 WordPress ShopBuilder Pro – Elementor WooCommerce Builder Addons plugin <= 2.2.0 - Arbitrary File Deletion vulnerability CVSS 3.1HIGH 8.6
Sources
- CVE-2022-50947 · CVE Program
- CVE-2022-50947 · NVD
- FIRST EPSS
- GHSA-mffq-rxr9-jpph · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences