Read the docs
TI-2023-00067 Aliases CVE-2023-0071GHSA-844g-3v4h-rp7p

WP Tabs < 2.1.17 - Contributor+ Stored XSS

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WP Tabs WordPress plugin before 2.1.17 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00534 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Tabs (Unknown): 2.1.17

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Tabsbefore 2.1.172.1.17Patch availableCNA
  • WP Tabs VendorUnknown Affected before 2.1.17 Fixed in 2.1.17 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shapedplugin:wp_tabs:*:*:*:*:*:wordpress:*:*before 2.1.17Vulnerableshapedplugin
  • cpe:2.3:a:shapedplugin:wp_tabs:*:*:*:*:*:wordpress:*:* Versions before 2.1.17 Vulnerable ·shapedplugin

Remediation

  • Fix · CNA WP Tabs (Unknown) Fixed in 2.1.17

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0071
  2. 2026-10-03 Alias added: GHSA-844g-3v4h-rp7p

References

  • TI-2024-10653 WP Tabs < 2.2.7 - Admin+ Stored XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-10537 WordPress WP Tabs Plugin <= 2.1.14 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2025-30504 WordPress WP Tabs plugin <= 2.2.12 - PHP Object Injection Vulnerability CVSS 3.1HIGH 7.2
  • TI-2023-28563 WordPress WP Tabs Plugin <= 2.2.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources