Read the docs
TI-2024-10653 Aliases CVE-2024-11503GHSA-wwgv-3xwq-6qmc

WP Tabs < 2.2.7 - Admin+ Stored XSS

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Tabs WordPress plugin before 2.2.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00279 20th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Tabs (Unknown): 2.2.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Tabsbefore 2.2.72.2.7Patch availableCNA
  • WP Tabs VendorUnknown Affected before 2.2.7 Fixed in 2.2.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shapedplugin:wp_tabs:*:*:*:*:*:wordpress:*:*before 2.2.7Vulnerableshapedplugin
  • cpe:2.3:a:shapedplugin:wp_tabs:*:*:*:*:*:wordpress:*:* Versions before 2.2.7 Vulnerable ·shapedplugin

Remediation

  • Fix · CNA WP Tabs (Unknown) Fixed in 2.2.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-11503
  2. 2026-10-03 Alias added: GHSA-wwgv-3xwq-6qmc

References

  • TI-2023-00067 WP Tabs < 2.1.17 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
  • TI-2023-10537 WordPress WP Tabs Plugin <= 2.1.14 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2025-30504 WordPress WP Tabs plugin <= 2.2.12 - PHP Object Injection Vulnerability CVSS 3.1HIGH 7.2
  • TI-2023-28563 WordPress WP Tabs Plugin <= 2.2.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources