Happyforms < 1.22.0 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Happyforms WordPress plugin before 1.22.0 does not validate and escape some of its block options before outputting them back in a page/post where the block is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00496 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Form builder to get in touch with visitors, grow your email list and collect payments — Happyforms (Unknown): 1.22.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Form builder to get in touch with visitors, grow your email list and collect payments — Happyforms | before 1.22.0 | 1.22.0 | Patch available | CNA |
- Form builder to get in touch with visitors, grow your email list and collect payments — Happyforms VendorUnknown Affected before 1.22.0 Fixed in 1.22.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:happyforms:happyforms:*:*:*:*:*:wordpress:*:* | before 1.22.0 | Vulnerable | Happyforms |
- cpe:2.3:a:happyforms:happyforms:*:*:*:*:*:wordpress:*:* Versions before 1.22.0 Vulnerable ·Happyforms
Remediation
- Fix · CNA Form builder to get in touch with visitors, grow your email list and collect payments — Happyforms (Unknown) Fixed in 1.22.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0096
- 2026-10-03 Alias added: GHSA-34rf-vmxr-2fgx
References
More Happyforms vulnerabilities
- TI-2024-09328 Happyforms < 1.26.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-26582 WordPress Happyforms Plugin <= 1.25.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-15562 WordPress Happyforms plugin <= 1.25.10 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-29652 WordPress Happyforms plugin <= 1.26.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-0096 · CVE Program
- CVE-2023-0096 · NVD
- FIRST EPSS
- GHSA-34rf-vmxr-2fgx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences