Happyforms < 1.26.3 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Happyforms WordPress plugin before 1.26.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00326 25th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Happyforms (Unknown): 1.26.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Happyforms | 1.26.2 to before 1.26.3 | 1.26.3 | Patch available | CNA |
- Happyforms VendorUnknown Affected 1.26.2 to before 1.26.3 Fixed in 1.26.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:happyforms:happyforms:*:*:*:*:*:wordpress:*:* | before 1.26.3 | Vulnerable | Happyforms |
- cpe:2.3:a:happyforms:happyforms:*:*:*:*:*:wordpress:*:* Versions before 1.26.3 Vulnerable ·Happyforms
Remediation
- Fix · CNA Happyforms (Unknown) Fixed in 1.26.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-10054
- 2026-10-03 Alias added: GHSA-4p3r-7jgv-wgrw
References
More Happyforms vulnerabilities
- TI-2023-00092 Happyforms < 1.22.0 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-26582 WordPress Happyforms Plugin <= 1.25.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-15562 WordPress Happyforms plugin <= 1.25.10 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-29652 WordPress Happyforms plugin <= 1.26.0 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-10054 · CVE Program
- CVE-2024-10054 · NVD
- FIRST EPSS
- GHSA-4p3r-7jgv-wgrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences