Stored XSS in usememos/memos
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A stored cross-site scripting (XSS) vulnerability was discovered in usememos/memos version 0.9.1. This vulnerability allows an attacker to upload a JavaScript file containing a malicious script and reference it in an HTML file. When the HTML file is accessed, the malicious script is executed. This can lead to the theft of sensitive information, such as login credentials, from users visiting the affected website. The issue has been fixed in version 0.10.0.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| usememos | usememos/memos | before 0.10.0 | 0.10.0 | Patch available | CNA |
| — | github.com/usememos/memos (Go) | before 0.10.0 | 0.10.0 | Patch available | GHSA-5r2g-59px-3q9w |
- usememos/memos Vendorusememos Affected before 0.10.0 Fixed in 0.10.0 Patch available CNA
- github.com/usememos/memos (Go) Vendor— Affected before 0.10.0 Fixed in 0.10.0 Patch available GHSA-5r2g-59px-3q9w
Remediation
- Fix · CNA usememos/memos (usememos) Fixed in 0.10.0
- Fix · GHSA-5r2g-59px-3q9w github.com/usememos/memos (Go) Fixed in 0.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0109
- 2026-10-03 Alias added: GHSA-5r2g-59px-3q9w
References
More usememos Memos vulnerabilities
- TI-2025-32234 The Memos application, up to version v0.24.3, allows for the embedding of markdown images… CVSS 3.1CRITICAL 9.8
- TI-2025-16796 elestio memos v0.23.0 is vulnerable to Server-Side Request Forgery (SSRF) due to… CVSS 3.1CRITICAL 9.8
- TI-2023-04328 Improper Access Control in usememos/memos CVSS 3.1CRITICAL 9.8
- TI-2022-04459 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04458 Cross-site Scripting (XSS) - Stored in usememos/memos CVSS 3.1CRITICAL 9.0
- TI-2022-04283 Authorization Bypass Through User-Controlled Key in usememos/memos CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-0109 · CVE Program
- CVE-2023-0109 · NVD
- FIRST EPSS
- GHSA-5r2g-59px-3q9w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences