Weaver Xtreme Theme Support < 6.2.7 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Weaver Xtreme Theme Support WordPress plugin before 6.2.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Weaver Xtreme Theme Support (Unknown): 6.2.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Weaver Xtreme Theme Support | before 6.2.7 | 6.2.7 | Patch available | CNA |
- Weaver Xtreme Theme Support VendorUnknown Affected before 6.2.7 Fixed in 6.2.7 Patch available CNA
Remediation
- Fix · CNA Weaver Xtreme Theme Support (Unknown) Fixed in 6.2.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0276
- 2026-10-03 Alias added: GHSA-2237-qj4m-4cpq
References
More wpweaver Weaver Xtreme Theme Support vulnerabilities
- TI-2023-04576 Weaver Xtreme Theme Support < 6.3.1 - Admin+ PHP Object Injection CVSS 3.1HIGH 7.2
- TI-2024-04592 Weaver Xtreme Theme Support <= 6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via div Shortcode CVSS 3.1MEDIUM 6.4
- TI-2023-06391 Weaver Xtreme <= 6.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-0276 · CVE Program
- CVE-2023-0276 · NVD
- FIRST EPSS
- GHSA-2237-qj4m-4cpq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences