Weaver Xtreme Theme Support < 6.3.1 - Admin+ PHP Object Injection
Priority HIGH 67CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-502.
Summary
The Weaver Xtreme Theme Support WordPress plugin before 6.3.1 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import a malicious file and a suitable gadget chain is present on the blog.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01186 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Weaver Xtreme Theme Support (Unknown): 6.3.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Weaver Xtreme Theme Support | before 6.3.1 | 6.3.1 | Patch available | CNA |
- Weaver Xtreme Theme Support VendorUnknown Affected before 6.3.1 Fixed in 6.3.1 Patch available CNA
Remediation
- Fix · CNA Weaver Xtreme Theme Support (Unknown) Fixed in 6.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4971
- 2026-10-03 Alias added: GHSA-q8w9-3c5w-2mhv
References
More wpweaver Weaver Xtreme Theme Support vulnerabilities
- TI-2023-00261 Weaver Xtreme Theme Support < 6.2.7 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-04592 Weaver Xtreme Theme Support <= 6.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via div Shortcode CVSS 3.1MEDIUM 6.4
- TI-2023-06391 Weaver Xtreme <= 6.3.0 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-4971 · CVE Program
- CVE-2023-4971 · NVD
- FIRST EPSS
- GHSA-q8w9-3c5w-2mhv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences