Read the docs
TI-2023-00318 Aliases CVE-2023-0334GHSA-w9f3-8wj5-2vvr

ShortPixel Adaptive Images < 3.6.3 - Reflected XSS

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The ShortPixel Adaptive Images WordPress plugin before 3.6.3 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against any high privilege users such as admin

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00881 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed ShortPixel Adaptive Images (Unknown): 3.6.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownShortPixel Adaptive Imagesbefore 3.6.33.6.3Patch availableCNA
  • ShortPixel Adaptive Images VendorUnknown Affected before 3.6.3 Fixed in 3.6.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:shortpixel:shortpixel_adaptive_images:*:*:*:*:*:wordpress:*:*before 3.6.3VulnerableShortPixel
  • cpe:2.3:a:shortpixel:shortpixel_adaptive_images:*:*:*:*:*:wordpress:*:* Versions before 3.6.3 Vulnerable ·ShortPixel

Remediation

  • Fix · CNA ShortPixel Adaptive Images (Unknown) Fixed in 3.6.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0334
  2. 2026-10-03 Alias added: GHSA-w9f3-8wj5-2vvr

References

  • TI-2023-15794 WordPress ShortPixel Adaptive Images Plugin <= 3.7.1 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2022-11887 WordPress ShortPixel Adaptive Images plugin <= 3.3.1 - Subscriber+ Plugin Settings Update vulnerability CVSS 3.1MEDIUM 4.3

Sources