WordPress ShortPixel Adaptive Images Plugin <= 3.7.1 is vulnerable to Cross Site Request Forgery (CSRF)
Priority MEDIUM 40CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
Cross-Site Request Forgery (CSRF) vulnerability in ShortPixel ShortPixel Adaptive Images – WebP, AVIF, CDN, Image Optimization plugin <= 3.7.1 versions.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00309 23rd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ShortPixel | ShortPixel Adaptive Images – WebP, AVIF, CDN, Image Optimization | up to 3.7.1 | — | No fix listed | CNA |
- ShortPixel Adaptive Images – WebP, AVIF, CDN, Image Optimization VendorShortPixel Affected up to 3.7.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:shortpixel:shortpixel_adaptive_images:*:*:*:*:*:wordpress:*:* | before 3.7.2 | Vulnerable | ShortPixel |
- cpe:2.3:a:shortpixel:shortpixel_adaptive_images:*:*:*:*:*:wordpress:*:* Versions before 3.7.2 Vulnerable ·ShortPixel
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-32512
- 2026-10-03 Alias added: GHSA-7236-9j44-cf2f
More Shortpixel Adaptive Images vulnerabilities
- TI-2023-00318 ShortPixel Adaptive Images < 3.6.3 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2022-11887 WordPress ShortPixel Adaptive Images plugin <= 3.3.1 - Subscriber+ Plugin Settings Update vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-32512 · CVE Program
- CVE-2023-32512 · NVD
- FIRST EPSS
- GHSA-7236-9j44-cf2f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences