Improper Neutralization of Equivalent Special Elements in btcpayserver/btcpayserver
Priority HIGH 77CWE-76Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Improper Neutralization of Equivalent Special Elements in GitHub repository btcpayserver/btcpayserver prior to 1.7.5.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.08118 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed btcpayserver/btcpayserver (btcpayserver): 1.7.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| btcpayserver | btcpayserver/btcpayserver | before 1.7.5 | 1.7.5 | Patch available | CNA |
- btcpayserver/btcpayserver Vendorbtcpayserver Affected before 1.7.5 Fixed in 1.7.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:btcpayserver:btcpay_server:*:*:*:*:*:*:*:* | before 1.7.5 | Vulnerable | btcpayserver |
- cpe:2.3:a:btcpayserver:btcpay_server:*:*:*:*:*:*:*:* Versions before 1.7.5 Vulnerable ·btcpayserver
Remediation
- Fix · CNA btcpayserver/btcpayserver (btcpayserver) Fixed in 1.7.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0493
References
More btcpayserver Btcpay Server vulnerabilities
- TI-2023-00834 Cross-site Scripting (XSS) - Stored in btcpayserver/btcpayserver CVSS 3.1MEDIUM 6.3
- TI-2023-01087 Improper Neutralization of Equivalent Special Elements in btcpayserver/btcpayserver CVSS 3.1MEDIUM 5.4
- TI-2022-14495 BTCPay Server 1.3.0 through 1.5.3 allows a remote attacker to obtain sensitive… CVSS 3.1HIGH 7.5
- TI-2021-10062 BTCPay Server before 1.0.6.0, when the payment button is used, has a privacy vulnerability. CVSS 3.1HIGH 7.5
- TI-2021-10059 BTCPay Server through 1.0.7.0 suffers from directory traversal, which allows an attacker… CVSS 3.1MEDIUM 6.7
- TI-2021-10064 BTCPay Server before 1.0.7.1 mishandles the policy setting in which users can register… CVSS 3.1MEDIUM 6.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences