Cross-site Scripting (XSS) - Stored in btcpayserver/btcpayserver
Priority MEDIUM 61CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - Stored in GitHub repository btcpayserver/btcpayserver prior to 1.7.12.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed btcpayserver/btcpayserver (btcpayserver): 1.7.12
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| btcpayserver | btcpayserver/btcpayserver | before 1.7.12 | 1.7.12 | Patch available | CNA |
- btcpayserver/btcpayserver Vendorbtcpayserver Affected before 1.7.12 Fixed in 1.7.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:btcpayserver:btcpay_server:*:*:*:*:*:*:*:* | before 1.7.12 | Vulnerable | btcpayserver |
- cpe:2.3:a:btcpayserver:btcpay_server:*:*:*:*:*:*:*:* Versions before 1.7.12 Vulnerable ·btcpayserver
Remediation
- Fix · CNA btcpayserver/btcpayserver (btcpayserver) Fixed in 1.7.12
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0879
- 2026-10-03 Alias added: GHSA-wh8v-v378-r87r
References
More btcpayserver Btcpay Server vulnerabilities
- TI-2023-00467 Improper Neutralization of Equivalent Special Elements in btcpayserver/btcpayserver CVSS 3.1HIGH 8.8
- TI-2023-01087 Improper Neutralization of Equivalent Special Elements in btcpayserver/btcpayserver CVSS 3.1MEDIUM 5.4
- TI-2022-14495 BTCPay Server 1.3.0 through 1.5.3 allows a remote attacker to obtain sensitive… CVSS 3.1HIGH 7.5
- TI-2021-10062 BTCPay Server before 1.0.6.0, when the payment button is used, has a privacy vulnerability. CVSS 3.1HIGH 7.5
- TI-2021-10059 BTCPay Server through 1.0.7.0 suffers from directory traversal, which allows an attacker… CVSS 3.1MEDIUM 6.7
- TI-2021-10064 BTCPay Server before 1.0.7.1 mishandles the policy setting in which users can register… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-0879 · CVE Program
- CVE-2023-0879 · NVD
- FIRST EPSS
- GHSA-wh8v-v378-r87r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences