Read the docs
TI-2023-00538 Aliases CVE-2023-0567

password_verify() always returns true for some invalid hashes

Priority LOW 39CWE-916Published · Updated

Key facts

Attack vector
Adjacent network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Partial Red Hat: 2 fixed, 3 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat.

Summary

In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, password_verify() function may accept some invalid Blowfish hashes as valid. If such invalid hash ever ends up in the password database, it may lead to an application allowing any password for this entry as valid.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00925 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial PHP (PHP Group): 8.0.28, 8.1.16, 8.2.3Red Hat: 4 advisoriesRed Hat: 2 fixed, 3 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHP GroupPHPbefore 8.0.28; before 8.1.16; before 8.2.38.0.28, 8.1.16, 8.2.3Patch availableCNA
  • PHP VendorPHP Group Affected before 8.0.28; before 8.1.16; before 8.2.3 Fixed in 8.0.28, 8.1.16, 8.2.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*8.0.0 to before 8.0.28; 8.1.0 to before 8.1.16; 8.2.0 to before 8.2.3VulnerablePHP
  • cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.0.28; 8.1.0 to before 8.1.16; 8.2.0 to before 8.2.3 Vulnerable ·PHP

Remediation

  • Fix · CNA PHP (PHP Group) Fixed in 8.0.28, 8.1.16, 8.2.3

Red Hat 4 advisories

  • RHSA-2024:10952 Released 2024-12-11 · Red Hat rating Moderate
    php:7.4 security update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.10.0+22485+a3539972.noarch::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.aarch64::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.ppc64le::php:7.4 +47
  • RHSA-2024:0387 Released 2024-01-24 · Red Hat rating Moderate
    php:8.1 security update
    • Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.21-1.module+el9.1.0.z+15477+cb86791d.noarch::php:8.1, php-8.1.27-1.module+el9.3.0.z+21063+f4ccb976.aarch64::php:8.1, php-8.1.27-1.module+el9.3.0.z+21063+f4ccb976.ppc64le::php:8.1 +47
  • RHSA-2023:5927 Released 2023-10-19 · Red Hat rating Important
    php:8.0 security update
    • Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.20-1.module+el8.6.0+13671+84712317.noarch::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.aarch64::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.ppc64le::php:8.0 +47
Show 1 more Red Hat advisories
  • RHSA-2023:5926 Released 2023-10-19 · Red Hat rating Important
    php security update
    • Red Hat Enterprise Linux AppStream (v. 9) php-8.0.30-1.el9_2, php-bcmath-8.0.30-1.el9_2, php-cli-8.0.30-1.el9_2 +22

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    PHP 8.0.28, 8.1.16, 8.2.3

    3 records Highest priority Priority MEDIUM 2 MEDIUM, 1 LOW

    Other records, highest priority first

    • TI-2023-00627 DoS vulnerability when parsing multipart request bodyPriority MEDIUM 42
    • TI-2023-00539 Array overrun in common path resolve codePriority MEDIUM 40

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 6AffectedNo fix planned: Out of support scope
Red Hat Enterprise Linux 7AffectedNo fix planned: Out of support scope
Red Hat Software CollectionsAffectedNo fix yet: Fix deferred
Red Hat Enterprise Linux AppStream (v. 8)Fixed RHSA-2023:5927, RHSA-2024:10952
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2023:5926, RHSA-2024:0387

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-0567

References

  • TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
  • TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
  • TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
  • TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
  • TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
See all 107 →

Sources