Path Traversal in NetModule NSRW
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The NetModule NSRW web administration interface is vulnerable to path traversals, which could lead to arbitrary file uploads and deletion. By uploading malicious files to the web root directory, authenticated users could gain remote command execution with elevated privileges. This issue affects NSRW: from 4.3.0.0 before 4.3.0.119, from 4.4.0.0 before 4.4.0.118, from 4.6.0.0 before 4.6.0.105, from 4.7.0.0 before 4.7.0.103.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| NetModule | NSRW | 4.3.0.0 to before 4.3.0.119; 4.4.0.0 to before 4.4.0.118; 4.6.0.0 to before 4.6.0.105; 4.7.0.0 to before 4.7.0.103 | 4.3.0.119, 4.4.0.118, 4.6.0.105, 4.7.0.103 | Patch available | CNA |
- NSRW VendorNetModule Affected 4.3.0.0 to before 4.3.0.119; 4.4.0.0 to before 4.4.0.118; 4.6.0.0 to before 4.6.0.105; 4.7.0.0 to before 4.7.0.103 Fixed in 4.3.0.119, 4.4.0.118, 4.6.0.105, 4.7.0.103 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:netmodule:netmodule_router_software:*:*:*:*:*:*:*:* | 4.3.0.0 to before 4.3.0.119; 4.4.0.0 to before 4.4.0.118; 4.6.0.0 to before 4.6.0.105; 4.7.0.0 to before 4.7.0.103 | Vulnerable | NetModule |
| cpe:2.3:h:netmodule:nb1601:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb1800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb1810:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb2800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb2810:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb3701:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb3800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:ng800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
- cpe:2.3:a:netmodule:netmodule_router_software:*:*:*:*:*:*:*:* Versions 4.3.0.0 to before 4.3.0.119; 4.4.0.0 to before 4.4.0.118; 4.6.0.0 to before 4.6.0.105; 4.7.0.0 to before 4.7.0.103 Vulnerable ·NetModule
- cpe:2.3:h:netmodule:nb1601:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb1800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb1810:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb2800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb2810:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb3701:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb3800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:ng800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
Remediation
- Fix · CNA NSRW (NetModule) Fixed in 4.3.0.119, 4.4.0.118, 4.6.0.105, 4.7.0.103
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
NetModule NSRW 4.3.0.119, 4.4.0.118 and 2 more versions
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2023-00816 Authenticated Command Injection in NetModule NSRWPriority HIGH 73
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0862
- 2026-10-03 Alias added: GHSA-hp6q-h54g-hcww
References
More Netmodule Router Software vulnerabilities
- TI-2023-00816 Authenticated Command Injection in NetModule NSRW CVSS 3.1HIGH 8.8
- TI-2023-24920 The web administration interface in NetModule Router Software (NRSW) 4.6 before 4.6.0.106… CVSS 3.1HIGH 8.4
- TI-2021-16665 Certain NetModule devices allow Limited Session Fixation via PHPSESSID. CVSS 3.1CRITICAL 9.8
- TI-2021-16666 Certain NetModule devices allow credentials via GET parameters to CLI-PHP. CVSS 3.1HIGH 8.8
- TI-2021-16664 Certain NetModule devices have Insecure Password Handling (cleartext or reversible… CVSS 3.1HIGH 7.5
Sources
- CVE-2023-0862 · CVE Program
- CVE-2023-0862 · NVD
- FIRST EPSS
- GHSA-hp6q-h54g-hcww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences