The web administration interface in NetModule Router Software (NRSW) 4.6 before 4.6.0.106…
Key facts
- Attack vector
- Adjacent network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-78.
Summary
The web administration interface in NetModule Router Software (NRSW) 4.6 before 4.6.0.106 and 4.8 before 4.8.0.101 executes an OS command constructed with unsanitized user input: shell metacharacters in the /admin/gnssAutoAlign.php device_id parameter. This occurs because another thread can be started before the trap that triggers the cleanup function. A successful exploit could allow an authenticated user to execute arbitrary commands with elevated privileges. NOTE: this is different from CVE-2023-0861 and CVE-2023-0862, which were fixed in version 4.6.0.105.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:netmodule:netmodule_router_software:*:*:*:*:*:*:*:* | before 4.6.0.105; 4.7.0.0 to before 4.7.0.103 | Vulnerable | NetModule |
| cpe:2.3:h:netmodule:nb1601:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb1800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb1810:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb2800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb2810:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb3701:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:nb3800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
| cpe:2.3:h:netmodule:ng800:-:*:*:*:*:*:*:* | not specified by NVD | Running on | NetModule |
- cpe:2.3:a:netmodule:netmodule_router_software:*:*:*:*:*:*:*:* Versions before 4.6.0.105; 4.7.0.0 to before 4.7.0.103 Vulnerable ·NetModule
- cpe:2.3:h:netmodule:nb1601:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb1800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb1810:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb2800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb2810:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb3701:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:nb3800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
- cpe:2.3:h:netmodule:ng800:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·NetModule
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-46306
- 2026-10-03 Alias added: GHSA-4qww-v3r6-7335
References
More Netmodule Router Software vulnerabilities
- TI-2023-00817 Path Traversal in NetModule NSRW CVSS 3.1HIGH 8.8
- TI-2023-00816 Authenticated Command Injection in NetModule NSRW CVSS 3.1HIGH 8.8
- TI-2021-16665 Certain NetModule devices allow Limited Session Fixation via PHPSESSID. CVSS 3.1CRITICAL 9.8
- TI-2021-16666 Certain NetModule devices allow credentials via GET parameters to CLI-PHP. CVSS 3.1HIGH 8.8
- TI-2021-16664 Certain NetModule devices have Insecure Password Handling (cleartext or reversible… CVSS 3.1HIGH 7.5
Sources
- CVE-2023-46306 · CVE Program
- CVE-2023-46306 · NVD
- FIRST EPSS
- GHSA-4qww-v3r6-7335 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences