Read the docs
TI-2023-00970 Aliases CVE-2023-1025GHSA-gpcv-pffg-3vfg

Simple File List < 6.0.10 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Simple File List WordPress plugin before 6.0.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Simple File List (Unknown): 6.0.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSimple File Listbefore 6.0.106.0.10Patch availableCNA
  • Simple File List VendorUnknown Affected before 6.0.10 Fixed in 6.0.10 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simplefilelist:simple_file_list:*:*:*:*:*:wordpress:*:*before 6.0.10VulnerableSimplefilelist
  • cpe:2.3:a:simplefilelist:simple_file_list:*:*:*:*:*:wordpress:*:* Versions before 6.0.10 Vulnerable ·Simplefilelist

Remediation

  • Fix · CNA Simple File List (Unknown) Fixed in 6.0.10

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-1025
  2. 2026-10-03 Alias added: GHSA-gpcv-pffg-3vfg

References

  • TI-2020-18982 Simple File List < 4.2.3 - Remote Code Execution CVSS 3.1CRITICAL 9.8
  • TI-2024-09406 Simple File List < 6.1.13 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 5.4
  • TI-2023-20823 WordPress Simple File List Plugin <= 6.1.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources