Read the docs
TI-2024-09406 Aliases CVE-2024-10146GHSA-c5rh-2mpx-r3x4

Simple File List < 6.1.13 - Reflected Cross-Site Scripting

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Simple File List WordPress plugin before 6.1.13 does not sanitise and escape a generated URL before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0062 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Simple File List (Unknown): 6.1.13

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSimple File Listbefore 6.1.136.1.13Patch availableCNA
  • Simple File List VendorUnknown Affected before 6.1.13 Fixed in 6.1.13 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:simplefilelist:simple_file_list:*:*:*:*:*:wordpress:*:*before 6.1.13VulnerableSimplefilelist
  • cpe:2.3:a:simplefilelist:simple_file_list:*:*:*:*:*:wordpress:*:* Versions before 6.1.13 Vulnerable ·Simplefilelist

Remediation

  • Fix · CNA Simple File List (Unknown) Fixed in 6.1.13

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-10146
  2. 2026-10-03 Alias added: GHSA-c5rh-2mpx-r3x4

References

  • TI-2020-18982 Simple File List < 4.2.3 - Remote Code Execution CVSS 3.1CRITICAL 9.8
  • TI-2023-00970 Simple File List < 6.0.10 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
  • TI-2023-20823 WordPress Simple File List Plugin <= 6.1.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources