Download Read More Excerpt Link <= 1.6.0 - Cross-Site Request Forgery to Settings Update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.
Summary
The Download Read More Excerpt Link plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.6.0. This is due to missing or incorrect nonce validation on the read_more_excerpt_link_menu_options() function. This makes it possible for unauthenticated attackers to update he plugin's settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| teckel | Read More Excerpt Link | up to 1.6.0 | — | No fix listed | CNA |
- Read More Excerpt Link Vendorteckel Affected up to 1.6.0 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:read_more_excerpt_link_project:read_more_excerpt_link:*:*:*:*:*:wordpress:*:* | up to 1.6.0 | Vulnerable | Read More Excerpt Link Project |
- cpe:2.3:a:read_more_excerpt_link_project:read_more_excerpt_link:*:*:*:*:*:wordpress:*:* Versions up to 1.6.0 Vulnerable ·Read More Excerpt Link Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1068
- 2026-10-03 Alias added: GHSA-pjvw-hfqr-5hxg
References
Advisory 1
More teckel vulnerabilities
- TI-2024-11671 Minify HTML <= 2.1.10 - - Regular Expressions Denial of Service CVSS 3.1MEDIUM 5.3
- TI-2026-02756 Minify HTML <= 2.1.12 - Cross-Site Request Forgery to Plugin Settings Update CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-1068 · CVE Program
- CVE-2023-1068 · NVD
- FIRST EPSS
- GHSA-pjvw-hfqr-5hxg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences