ND Shortcodes < 7.0 - Subscriber+ LFI
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The ND Shortcodes WordPress plugin before 7.0 does not validate some shortcode attributes before using them to generate paths passed to include function/s, allowing any authenticated users such as subscriber to perform LFI attacks
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | ND Shortcodes | before 7.0 | 7.0 | Patch available | CNA |
- ND Shortcodes VendorUnknown Affected before 7.0 Fixed in 7.0 Patch available CNA
Remediation
- Fix · CNA ND Shortcodes (Unknown) Fixed in 7.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
ND Shortcodes 7.0
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2022-04224 ND Shortcodes < 7.0 - Contributor+ Stored XSS via ShortcodesPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1273
- 2026-10-03 Alias added: GHSA-jgrp-j9c7-qv87
References
More nicdark Nd Shortcodes vulnerabilities
- TI-2022-04224 ND Shortcodes < 7.0 - Contributor+ Stored XSS via Shortcodes CVSS 3.1MEDIUM 5.4
- TI-2024-04844 ND Shortcodes <= 7.5 - Authenticated (Author+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2023-1273 · CVE Program
- CVE-2023-1273 · NVD
- FIRST EPSS
- GHSA-jgrp-j9c7-qv87 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences