tagDiv Composer < 4.0 - Reflected Cross-site Scripting
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The tagDiv Composer WordPress plugin before 4.0 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00506 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed tagDiv Composer (Unknown): 4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | tagDiv Composer | before 4.0 | 4.0 | Patch available | CNA |
- tagDiv Composer VendorUnknown Affected before 4.0 Fixed in 4.0 Patch available CNA
Remediation
- Fix · CNA tagDiv Composer (Unknown) Fixed in 4.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1596
- 2026-10-03 Alias added: GHSA-qm9g-fvc6-c76p
References
More tagDiv Composer vulnerabilities
- TI-2025-03082 tagDiv Composer <= 5.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via Multiple Shortcodes CVSS 3.1MEDIUM 6.4
Sources
- CVE-2023-1596 · CVE Program
- CVE-2023-1596 · NVD
- FIRST EPSS
- GHSA-qm9g-fvc6-c76p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences