Information disclosure in linked message previews
Priority LOW 30CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Mattermost allows an attacker to request a preview of an existing message when creating a new message via the createPost API call, disclosing the contents of the linked message.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00537 45th percentileScored 2026-11-07
Fix Fixed Mattermost (Mattermost): 7.8.1, 7.7.2, 7.1.6github.com/mattermost/mattermost-server/v6 (Go): 7.1.6, 6.0.0-20230301145909-10be118d99a5+1 more product
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mattermost | Mattermost | 6.3.0 – 7.7.1; 6.3.0 – 7.1.5; 6.3.0 – 7.8.0 | 7.8.1, 7.7.2, 7.1.6 | Patch available | CNA |
| — | github.com/mattermost/mattermost-server/v6 (Go) | 6.3.0 to before 7.1.6 | 7.1.6 | Patch available | GHSA-3wq5-3f56-v5xc |
| — | github.com/mattermost/mattermost-server (Go) | 7.8.0 to before 7.8.1 | 7.8.1 | Patch available | GHSA-3wq5-3f56-v5xc |
| — | github.com/mattermost/mattermost-server (Go) | 7.7.0 to before 7.7.2 | 7.7.2 | Patch available | GHSA-3wq5-3f56-v5xc |
| — | github.com/mattermost/mattermost-server (Go) | 7.1.0 to before 7.1.6 | 7.1.6 | Patch available | GHSA-3wq5-3f56-v5xc |
| — | github.com/mattermost/mattermost-server/v6 (Go) | 6.0.0-20211025164829-f7a8147b825c to before 6.0.0-20230301145909-10be118d99a5 | 6.0.0-20230301145909-10be118d99a5 | Patch available | GHSA-3wq5-3f56-v5xc |
| — | github.com/mattermost/mattermost-server (Go) | 1.4.1-0.20211025164829-f7a8147b825c to before 1.4.1-0.20230301145909-10be118d99a5 | 1.4.1-0.20230301145909-10be118d99a5 | Patch available | GHSA-3wq5-3f56-v5xc |
- Mattermost VendorMattermost Affected 6.3.0 – 7.7.1; 6.3.0 – 7.1.5; 6.3.0 – 7.8.0 Fixed in 7.8.1, 7.7.2, 7.1.6 Patch available CNA
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected 6.3.0 to before 7.1.6 Fixed in 7.1.6 Patch available GHSA-3wq5-3f56-v5xc
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 7.8.0 to before 7.8.1 Fixed in 7.8.1 Patch available GHSA-3wq5-3f56-v5xc
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 7.7.0 to before 7.7.2 Fixed in 7.7.2 Patch available GHSA-3wq5-3f56-v5xc
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 7.1.0 to before 7.1.6 Fixed in 7.1.6 Patch available GHSA-3wq5-3f56-v5xc
- github.com/mattermost/mattermost-server/v6 (Go) Vendor— Affected 6.0.0-20211025164829-f7a8147b825c to before 6.0.0-20230301145909-10be118d99a5 Fixed in 6.0.0-20230301145909-10be118d99a5 Patch available GHSA-3wq5-3f56-v5xc
- github.com/mattermost/mattermost-server (Go) Vendor— Affected 1.4.1-0.20211025164829-f7a8147b825c to before 1.4.1-0.20230301145909-10be118d99a5 Fixed in 1.4.1-0.20230301145909-10be118d99a5 Patch available GHSA-3wq5-3f56-v5xc
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* | before 7.1.6 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:7.7.1:*:*:*:*:*:*:* | 7.7.1 | Vulnerable | Mattermost |
| cpe:2.3:a:mattermost:mattermost_server:7.8.0:*:*:*:*:*:*:* | 7.8.0 | Vulnerable | Mattermost |
- cpe:2.3:a:mattermost:mattermost_server:*:*:*:*:*:*:*:* Versions before 7.1.6 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:7.7.1:*:*:*:*:*:*:* Versions 7.7.1 Vulnerable ·Mattermost
- cpe:2.3:a:mattermost:mattermost_server:7.8.0:*:*:*:*:*:*:* Versions 7.8.0 Vulnerable ·Mattermost
Remediation
- Fix · CNA Mattermost (Mattermost) Fixed in 7.8.1, 7.7.2, 7.1.6
- Fix · GHSA-3wq5-3f56-v5xc github.com/mattermost/mattermost-server/v6 (Go) Fixed in 7.1.6 Advisory →
- Fix · GHSA-3wq5-3f56-v5xc github.com/mattermost/mattermost-server (Go) Fixed in 7.8.1 Advisory →
- Fix · GHSA-3wq5-3f56-v5xc github.com/mattermost/mattermost-server (Go) Fixed in 7.7.2 Advisory →
- Fix · GHSA-3wq5-3f56-v5xc github.com/mattermost/mattermost-server (Go) Fixed in 7.1.6 Advisory →
- Fix · GHSA-3wq5-3f56-v5xc github.com/mattermost/mattermost-server/v6 (Go) Fixed in 6.0.0-20230301145909-10be118d99a5 Advisory →
- Fix · GHSA-3wq5-3f56-v5xc github.com/mattermost/mattermost-server (Go) Fixed in 1.4.1-0.20230301145909-10be118d99a5 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1777
- 2026-10-03 Alias added: GHSA-3wq5-3f56-v5xc
References
More Mattermost Server vulnerabilities
- TI-2025-18933 Arbitrary file read in Mattermost Boards via import & export board archive CVSS 3.1CRITICAL 9.9
- TI-2025-04465 Path Traversal Leading to RCE by Any Authenticated Mattermost User CVSS 3.1CRITICAL 9.9
- TI-2017-14068 An issue was discovered in Mattermost Server before 3.6.2. CVSS 3.1CRITICAL 9.8
- TI-2017-14060 An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. CVSS 3.1CRITICAL 9.8
- TI-2017-14048 An issue was discovered in Mattermost Server before 4.1.0, 4.0.4, and 3.10.3. CVSS 3.1CRITICAL 9.8
- TI-2025-14360 Arbitrary file read via block duplication in Mattermost Boards CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-1777 · CVE Program
- CVE-2023-1777 · NVD
- FIRST EPSS
- GHSA-3wq5-3f56-v5xc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences