WP Popups < 2.1.5.1 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WP Popups WordPress plugin before 2.1.5.1 does not properly escape the href attribute of its spu-facebook-page shortcode before outputting it back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks. This is due to an insufficient fix of CVE-2023-24003
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Popups | before 2.1.5.1 | 2.1.5.1 | Patch available | CNA |
- WP Popups VendorUnknown Affected before 2.1.5.1 Fixed in 2.1.5.1 Patch available CNA
Remediation
- Fix · CNA WP Popups (Unknown) Fixed in 2.1.5.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1905
- 2026-10-03 Alias added: GHSA-qr32-r782-79j4
References
More Timersys Wp Popups vulnerabilities
- TI-2022-04312 WP Popups < 2.1.4.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-09790 WordPress WP Popups Plugin <= 2.1.4.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-1905 · CVE Program
- CVE-2023-1905 · NVD
- FIRST EPSS
- GHSA-qr32-r782-79j4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences