Read the docs
TI-2023-02171 Aliases CVE-2023-2315GHSA-v4j2-cwmm-xg89

Improper input validation in Opencart

Priority HIGH 71CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2 allows an authenticated user with access/modify privilege on the Log component to empty out arbitrary files on the server

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01037 64th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed opencart/opencart (Packagist): 4.0.2.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—opencart/opencart (Packagist)4.0.0.0 to before 4.0.2.34.0.2.3Patch availableGHSA-v4j2-cwmm-xg89
  • opencart/opencart (Packagist) Vendor— Affected 4.0.0.0 to before 4.0.2.3 Fixed in 4.0.2.3 Patch available GHSA-v4j2-cwmm-xg89

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opencart:opencart:*:*:*:*:*:*:*:*4.0.0.0 – 4.0.2.2VulnerableOpenCart
  • cpe:2.3:a:opencart:opencart:*:*:*:*:*:*:*:* Versions 4.0.0.0 – 4.0.2.2 Vulnerable ·OpenCart

Remediation

  • Fix · GHSA-v4j2-cwmm-xg89 opencart/opencart (Packagist) Fixed in 4.0.2.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2315
  2. 2026-10-03 Alias added: GHSA-v4j2-cwmm-xg89

References

  • TI-2023-21572 OpenCart CMS v4.0.2.2 was discovered to lack a protective mechanism on its login page… CVSS 3.1CRITICAL 9.8
  • TI-2024-38428 OpenCart Core 4.0.2.3 SQL Injection via search Parameter CVSS 4.0HIGH 8.8
  • TI-2023-25651 An issue discovered in OpenCart 4.0.0.0 to 4.0.2.3 allows authenticated backend users… CVSS 3.1HIGH 8.8
  • TI-2024-14270 SQL injection in opencart/opencart CVSS 3.1HIGH 8.1
  • TI-2024-24380 OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function. CVSS 3.1HIGH 7.2
  • TI-2024-14275 Improper input validation in opencart/opencart CVSS 3.1HIGH 7.2
See all 38 →

Sources