Priority HIGH 82
OpenCart CMS v4.0.2.2 was discovered to lack a protective mechanism on its login page against excessive login attempts, allowing unauthenticated attackers to gain access to the application via a brute force attack to the…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.01288 · Published 2023-09-12 · No fix listed CWE-307
Priority HIGH 77
OpenCart Core 4.0.2.3 contains a SQL injection vulnerability that allows unauthenticated attackers to manipulate database queries by injecting SQL code through the 'search' parameter.
CVSS 4.0HIGH 8.8· Network · No auth · No interaction · EPSS 0.00344 · Published 2026-03-25 · Fixed in 4.1.0.0 CWE-89
Priority HIGH 73
An issue discovered in OpenCart 4.0.0.0 to 4.0.2.3 allows authenticated backend users having common/security write privilege can write arbitrary untrusted data inside config.php and admin/config.php, resulting in remote…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01779 · Published 2023-11-15 · No fix listed CWE-94
Priority HIGH 71
Path Traversal in OpenCart versions 4.0.0.0 to 4.0.2.2 allows an authenticated user with access/modify privilege on the Log component to empty out arbitrary files on the server
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01037 · Published 2023-09-26 · Fixed in 4.0.2.3 CWE-20
Priority HIGH 68
This affects versions of the package opencart/opencart from 0.0.0.
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.1908 · Published 2024-06-22 · No fix listed CWE-89
Priority HIGH 67
OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.00923 · Published 2024-12-18 · No fix listed CWE-94
Priority HIGH 67
This affects versions of the package opencart/opencart from 4.0.0.0.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.00719 · Published 2024-06-22 · No fix listed CWE-20
Priority HIGH 67
This affects versions of the package opencart/opencart from 4.0.0.0.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.14126 · Published 2024-06-22 · No fix listed CWE-29
Priority MEDIUM 61
A security flaw has been discovered in OpenCart up to 4.1.0.3.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.00407 · Published 2025-12-28 · No fix listed CWE-362
Priority MEDIUM 56
A vulnerability has been found in OpenCart 4.0.2.3.
CVSS 4.0MEDIUM 5.1· Network · High privileges · No interaction · EPSS 0.00296 · Published 2026-03-08 · No fix listed CWE-1336
Priority MEDIUM 56
OpenCart 3.0.3.7 allows users to obtain database information or read server files through SQL injection in the background.
CVSS 3.1MEDIUM 4.9· Network · High privileges · No interaction · EPSS 0.00875 · Published 2022-11-03 · No fix listed CWE-89
Priority MEDIUM 52
The Cart::getProducts method in system/library/cart.php in OpenCart 1.5.6.4 and earlier allows remote attackers to conduct server-side request forgery (SSRF) attacks or possibly conduct XML External Entity (XXE) attacks…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.06604 · Published 2018-03-20 · No fix listed CWE-611
Priority MEDIUM 44
This affects versions of the package opencart/opencart from 4.0.0.0.
CVSS 4.0LOW 2.1· Network · No auth · User interaction · EPSS 0.00391 · Published 2024-06-22 · No fix listed CWE-79
Priority MEDIUM 44
This affects versions of the package opencart/opencart from 4.0.0.0 and before 4.1.0.0.
CVSS 4.0LOW 2.1· Network · No auth · User interaction · EPSS 0.00366 · Published 2024-06-22 · Fixed in 4.1.0.0 CWE-79
Priority MEDIUM 44
This affects versions of the package opencart/opencart from 4.0.0.0.
CVSS 4.0LOW 2.1· Network · No auth · User interaction · EPSS 0.00366 · Published 2024-06-22 · No fix listed CWE-79
Priority LOW 39
/upload/catalog/controller/account/password.php in OpenCart through 3.0.2.0 has CSRF via the index.php?route=account/password URI to change a user's password.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.00716 · Published 2018-07-02 · No fix listed CWE-352
Priority LOW 39
The "program extension upload" feature in OpenCart through 3.0.2.0 has a six-step process (upload, install, unzip, move, xml, remove) that allows attackers to execute arbitrary code if the remove step is skipped, because…
CVSS 3.0HIGH 8.0· Network · High privileges · No interaction · EPSS 0.02296 · Published 2018-05-26 · No fix listed CWE-22
Priority LOW 38
In OpenCart 1.4.7 to 1.5.5.1, implemented anti-traversal code in filemanager.php is ineffective and can be bypassed.
CVSS 3.1MEDIUM 6.5· Network · High privileges · No interaction · EPSS 0.06579 · Published 2022-06-24 · No fix listed CWE-22
Priority LOW 36
SQL injection vulnerability in OpenCart v.2.2.00 thru 3.0.3.2 allows a remote attacker to execute arbitrary code via the Fba plugin function in upload/admin/index.php.
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01127 · Published 2023-06-20 · No fix listed CWE-89
Priority LOW 36
SQL injection vulnerability in OpenCart 1.1.8 allows remote attackers to execute arbitrary SQL commands via the order parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01692 · Published 2009-03-20 · No fix listed CWE-89
Priority LOW 35
SQL injection vulnerability in index.php in OpenCart 1.3.2 allows remote attackers to execute arbitrary SQL commands via the page parameter.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.01113 · Published 2010-03-09 · No fix listed CWE-89
Priority LOW 34
SQL injection vulnerability in the updateAmazonOrderTracking function in upload/admin/model/openbay/amazon.php in OpenCart before version 2.3.0.0 allows remote authenticated administrators to execute arbitrary SQL comman…
CVSS 3.0HIGH 7.2· Network · High privileges · No interaction · EPSS 0.0141 · Published 2017-08-31 · No fix listed CWE-89
Priority LOW 32
Directory traversal vulnerability in index.php in OpenCart 1.1.8 allows remote attackers to read arbitrary files via a ..
CVSS 2.0MEDIUM 5.0· Network · No auth · Interaction — · EPSS 0.06444 · Published 2009-05-12 · No fix listed CWE-22
Priority LOW 31
Cross-site request forgery (CSRF) vulnerability in index.php in OpenCart 1.4 allows remote attackers to hijack the authentication of an application administrator for requests that create an administrative account via a P…
CVSS 2.0MEDIUM 6.8· Network · No auth · Interaction — · EPSS 0.00599 · Published 2010-04-29 · No fix listed CWE-352
Priority LOW 30
Cross-site scripting (XSS) vulnerability in OpenCart before 2.1.0.2 allows remote attackers to inject arbitrary web script or HTML via the zone_id parameter to index.php.
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01515 · Published 2016-01-12 · No fix listed CWE-79
Load more