WP ERP < 1.12.4 - Reflected Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The ERP WordPress plugin before 1.12.4 does not sanitise and escape the employee_name parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting | before 1.12.4 | 1.12.4 | Patch available | CNA |
- WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting VendorUnknown Affected before 1.12.4 Fixed in 1.12.4 Patch available CNA
Remediation
- Fix · CNA WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting (Unknown) Fixed in 1.12.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WP ERP | Complete HR solution with recruitment & job listings | WooCommerce CRM & Accounting 1.12.4
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-02570 WP ERP < 1.12.4 - Admin+ SQL InjectionPriority HIGH 67
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2743
- 2026-10-03 Alias added: GHSA-jhmf-mhgj-hjcw
References
More weDevs Wp Erp vulnerabilities
- TI-2024-11873 WP ERP < 1.13.4 - Custom+ Unauthorized Access to Terminated Employee Information CVSS 3.1HIGH 7.5
- TI-2023-02570 WP ERP < 1.12.4 - Admin+ SQL Injection CVSS 3.1HIGH 7.2
- TI-2024-11869 WP ERP | Complete HR solution with recruitment < 1.13.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-06178 WP ERP <= 1.13.0 - Authenticated (Accounting Manager+) SQL Injection via vendor_id CVSS 3.1HIGH 8.8
- TI-2024-01088 SQL injection in weDevs ERP: Complete HR, Accounting & CRM Suite with WooCommerce CRM… CVSS 3.1HIGH 7.2
- TI-2024-14433 WordPress WP ERP Plugin <= 1.12.8 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
Sources
- CVE-2023-2743 · CVE Program
- CVE-2023-2743 · NVD
- FIRST EPSS
- GHSA-jhmf-mhgj-hjcw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences