Leyka < 3.30.4 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Leyka WordPress plugin before 3.30.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00448 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Leyka (Unknown): 3.30.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Leyka | before 3.30.4 | 3.30.4 | Patch available | CNA |
- Leyka VendorUnknown Affected before 3.30.4 Fixed in 3.30.4 Patch available CNA
Remediation
- Fix · CNA Leyka (Unknown) Fixed in 3.30.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2995
- 2026-10-03 Alias added: GHSA-6vm8-mfgv-3gj5
References
More Te-st Leyka vulnerabilities
- TI-2023-20457 WordPress Leyka Plugin <= 3.30.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-16484 WordPress Leyka Plugin <= 3.30.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-12182 WordPress Leyka Plugin <= 3.29.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-04528 Leyka <= 3.30.7 - Authenticated (Subscriber+) Sensitive Information Exposure CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-2995 · CVE Program
- CVE-2023-2995 · NVD
- FIRST EPSS
- GHSA-6vm8-mfgv-3gj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences