MStore API < 3.9.8 - Unauthenticated Blind SQLi
Priority HIGH 82Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The MStore API WordPress plugin before 3.9.8 does not sanitise and escape a parameter before using it in a SQL statement, leading to a Blind SQL injection exploitable by unauthenticated users. This is only exploitable if the site owner elected to pay to get access to the plugins' pro features, and uses the woocommerce-appointments plugin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.05505 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed MStore API (Unknown): 3.9.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | MStore API | before 3.9.8 | 3.9.8 | Patch available | CNA |
- MStore API VendorUnknown Affected before 3.9.8 Fixed in 3.9.8 Patch available CNA
Remediation
- Fix · CNA MStore API (Unknown) Fixed in 3.9.8
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3077
- 2026-10-03 Alias added: GHSA-95vf-7jgr-4c75
References
More inspireui Mstore Api vulnerabilities
- TI-2023-02559 MStore API <= 3.9.2 - Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2023-02882 MStore API < 3.9.9 - Unauthenticated Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2023-03070 MStore API <= 4.10.7 - Unauthorized Account Access and Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2023-02994 MStore API <= 4.0.1 - Unauthenticated SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-02561 MStore API <= 3.9.1 - Authentication Bypass CVSS 3.1CRITICAL 9.8
- TI-2023-02934 MStore API < 3.9.7 - Subscriber+ Unauthorized Settings Update CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-3077 · CVE Program
- CVE-2023-3077 · NVD
- FIRST EPSS
- GHSA-95vf-7jgr-4c75 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences