NextGEN Gallery < 3.39 - Admin+ Arbitrary File Read and Delete
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-552.
Summary
The WordPress Gallery Plugin WordPress plugin before 3.39 is vulnerable to Arbitrary File Read and Delete due to a lack of input parameter validation in the `gallery_edit` function, allowing an attacker to access arbitrary resources on the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Gallery Plugin | before 3.39 | 3.39 | Patch available | CNA |
- WordPress Gallery Plugin VendorUnknown Affected before 3.39 Fixed in 3.39 Patch available CNA
Remediation
- Fix · CNA WordPress Gallery Plugin (Unknown) Fixed in 3.39
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
WordPress Gallery Plugin 3.39
3 records Highest priority Priority HIGH 2 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-02956 NextGEN Gallery < 3.39 - Admin+ PHAR DeserializationPriority HIGH 72
- TI-2023-03071 NextGEN Gallery < 3.39 - Admin+ Local File InclusionPriority MEDIUM 56
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3155
- 2026-10-03 Alias added: GHSA-4mq9-mp5g-r83q
References
More Imagely Nextgen Gallery vulnerabilities
- TI-2023-02956 NextGEN Gallery < 3.39 - Admin+ PHAR Deserialization CVSS 3.1HIGH 7.5
- TI-2019-10666 A SQL injection vulnerability exists in the Imagely NextGEN Gallery plugin before 3.2.11… CVSS 3.0CRITICAL 9.8
- TI-2024-05058 NextGEN Gallery < 3.59.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 5.9
- TI-2013-03217 NextGEN Gallery plugin before 1.9.13 for WordPress: ngggallery.php file upload CVSS 3.1CRITICAL 9.8
- TI-2024-02901 WordPress Gallery Plugin – NextGEN Gallery <= 3.59 - Missing Authorization to Unauthenticated Information Disclosure CVSS 3.1MEDIUM 5.3
- TI-2023-03071 NextGEN Gallery < 3.39 - Admin+ Local File Inclusion CVSS 3.1MEDIUM 4.9
Sources
- CVE-2023-3155 · CVE Program
- CVE-2023-3155 · NVD
- FIRST EPSS
- GHSA-4mq9-mp5g-r83q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences