NextGEN Gallery < 3.59.3 - Admin+ Stored XSS
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Photo Gallery, Sliders, Proofing and WordPress plugin before 3.59.3 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00375 31st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Photo Gallery, Sliders, Proofing and Themes (Unknown): 3.59.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Photo Gallery, Sliders, Proofing and Themes | before 3.59.3 | 3.59.3 | Patch available | CNA |
- Photo Gallery, Sliders, Proofing and Themes VendorUnknown Affected before 3.59.3 Fixed in 3.59.3 Patch available CNA
Remediation
- Fix · CNA Photo Gallery, Sliders, Proofing and Themes (Unknown) Fixed in 3.59.3
Timeline
- 2026-10-02 Threatist record created from CVE-2024-5442
- 2026-10-03 Alias added: GHSA-pc76-wwrm-9rgw
References
More Imagely Nextgen Gallery vulnerabilities
- TI-2023-02956 NextGEN Gallery < 3.39 - Admin+ PHAR Deserialization CVSS 3.1HIGH 7.5
- TI-2019-10666 A SQL injection vulnerability exists in the Imagely NextGEN Gallery plugin before 3.2.11… CVSS 3.0CRITICAL 9.8
- TI-2023-02957 NextGEN Gallery < 3.39 - Admin+ Arbitrary File Read and Delete CVSS 3.1HIGH 7.2
- TI-2013-03217 NextGEN Gallery plugin before 1.9.13 for WordPress: ngggallery.php file upload CVSS 3.1CRITICAL 9.8
- TI-2024-02901 WordPress Gallery Plugin – NextGEN Gallery <= 3.59 - Missing Authorization to Unauthenticated Information Disclosure CVSS 3.1MEDIUM 5.3
- TI-2023-03071 NextGEN Gallery < 3.39 - Admin+ Local File Inclusion CVSS 3.1MEDIUM 4.9
Sources
- CVE-2024-5442 · CVE Program
- CVE-2024-5442 · NVD
- FIRST EPSS
- GHSA-pc76-wwrm-9rgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences