Read the docs
TI-2023-03192 Aliases CVE-2023-3414GHSA-rchx-rvh2-vx5j

Cross-Site Request Forgery (CSRF) in Jenkins Plug-in for ServiceNow DevOps

Priority LOW 29CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering, Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352 and CWE-200.

Summary

A cross-site request forgery vulnerability exists in versions of the Jenkins Plug-in for ServiceNow DevOps prior to 1.38.1 that, if exploited successfully, could cause the unwanted exposure of sensitive information. To address this issue, apply the 1.38.1 version of the Jenkins plug-in for ServiceNow DevOps on your Jenkins server. No changes are required on your instances of the Now Platform.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00413 35th percentileScored 2026-11-07
Fix Fixed Jenkins plug-in for ServiceNow DevOps (ServiceNow): 1.38.1io.jenkins.plugins:servicenow-devops (Maven): 1.38.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ServiceNowJenkins plug-in for ServiceNow DevOpsbefore 1.38.11.38.1Patch availableCNA
—io.jenkins.plugins:servicenow-devops (Maven)before 1.38.11.38.1Patch availableGHSA-rchx-rvh2-vx5j
  • Jenkins plug-in for ServiceNow DevOps VendorServiceNow Affected before 1.38.1 Fixed in 1.38.1 Patch available CNA
  • io.jenkins.plugins:servicenow-devops (Maven) Vendor— Affected before 1.38.1 Fixed in 1.38.1 Patch available GHSA-rchx-rvh2-vx5j

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jenkins:servicenow_devops:*:*:*:*:*:jenkins:*:*before 1.38.1VulnerableJenkins
  • cpe:2.3:a:jenkins:servicenow_devops:*:*:*:*:*:jenkins:*:* Versions before 1.38.1 Vulnerable ·Jenkins

Remediation

  • Fix · CNA Jenkins plug-in for ServiceNow DevOps (ServiceNow) Fixed in 1.38.1
  • Fix · GHSA-rchx-rvh2-vx5j io.jenkins.plugins:servicenow-devops (Maven) Fixed in 1.38.1 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    ServiceNow Jenkins plug-in for ServiceNow DevOps 1.38.1

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2023-03216 Missing Authorization in Jenkins plug-in for ServiceNow DevOpsPriority LOW 35

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-3414
  2. 2026-10-03 Alias added: GHSA-rchx-rvh2-vx5j

References

  • TI-2024-04841 Incomplete Input Validation in GlideExpression Script KEVCVSS 4.0CRITICAL 9.2
  • TI-2024-04536 Jelly Template Injection Vulnerability in ServiceNow UI Macros KEVCVSS 4.0CRITICAL 9.3
  • TI-2025-11396 Unauthenticated Privilege Escalation in ServiceNow AI Platform CVSS 4.0CRITICAL 9.3
  • TI-2026-15447 Unauthenticated Remote Code Execution in GraphQL Composite Data API CVSS 4.0CRITICAL 10.0
  • TI-2026-52569 Unauthenticated SQL Injection via Dynamic Schema ORDER BY Clause CVSS 4.0CRITICAL 10.0
  • TI-2026-15448 Unauthenticated Privilege Escalation via System Configuration Image Upload Processor CVSS 4.0CRITICAL 10.0
See all 40 →

Sources