Missing Authorization in Jenkins plug-in for ServiceNow DevOps
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A missing authorization vulnerability exists in versions of the Jenkins Plug-in for ServiceNow DevOps prior to 1.38.1 that, if exploited successfully, could cause the unwanted exposure of sensitive information. To address this issue, apply the 1.38.1 version of the Jenkins plug-in for ServiceNow DevOps on your Jenkins server. No changes are required on your instances of the Now Platform.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ServiceNow | Jenkins plug-in for ServiceNow DevOps | before 1.38.1 | 1.38.1 | Patch available | CNA |
| — | io.jenkins.plugins:servicenow-devops (Maven) | before 1.38.1 | 1.38.1 | Patch available | GHSA-cj2x-r74q-vcx9 |
- Jenkins plug-in for ServiceNow DevOps VendorServiceNow Affected before 1.38.1 Fixed in 1.38.1 Patch available CNA
- io.jenkins.plugins:servicenow-devops (Maven) Vendor— Affected before 1.38.1 Fixed in 1.38.1 Patch available GHSA-cj2x-r74q-vcx9
Remediation
- Fix · CNA Jenkins plug-in for ServiceNow DevOps (ServiceNow) Fixed in 1.38.1
- Fix · GHSA-cj2x-r74q-vcx9 io.jenkins.plugins:servicenow-devops (Maven) Fixed in 1.38.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
ServiceNow Jenkins plug-in for ServiceNow DevOps 1.38.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-03192 Cross-Site Request Forgery (CSRF) in Jenkins Plug-in for ServiceNow DevOpsPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3442
- 2026-10-03 Alias added: GHSA-cj2x-r74q-vcx9
References
Advisory 2
Other 4
- https://github.com/jenkinsci/servicenow-devops-plugin/commit/67192e24099787ad732b41d581f20714d4253921
- https://github.com/jenkinsci/servicenow-devops-plugin/commit/d7d2422b016995402dd245d9c9c5c2f4cf00c691
- https://github.com/jenkinsci/servicenow-devops-plugin
- https://github.com/jenkinsci/servicenow-devops-plugin/releases/tag/v1.38.1
More ServiceNow vulnerabilities
- TI-2024-04841 Incomplete Input Validation in GlideExpression Script KEVCVSS 4.0CRITICAL 9.2
- TI-2024-04536 Jelly Template Injection Vulnerability in ServiceNow UI Macros KEVCVSS 4.0CRITICAL 9.3
- TI-2025-11396 Unauthenticated Privilege Escalation in ServiceNow AI Platform CVSS 4.0CRITICAL 9.3
- TI-2026-15447 Unauthenticated Remote Code Execution in GraphQL Composite Data API CVSS 4.0CRITICAL 10.0
- TI-2026-52569 Unauthenticated SQL Injection via Dynamic Schema ORDER BY Clause CVSS 4.0CRITICAL 10.0
- TI-2026-15448 Unauthenticated Privilege Escalation via System Configuration Image Upload Processor CVSS 4.0CRITICAL 10.0
Sources
- CVE-2023-3442 · CVE Program
- CVE-2023-3442 · NVD
- FIRST EPSS
- GHSA-cj2x-r74q-vcx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences