Incorrect Authorization in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-863.
Summary
An issue has been discovered in GitLab affecting all versions starting from 12.1 before 16.4.3, all versions starting from 16.5 before 16.5.3, all versions starting from 16.6 before 16.6.1. It was possible for a Guest user to add an emoji on confidential work items.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.1 to before 16.4.3; 16.5 to before 16.5.3; 16.6 to before 16.6.1 | 16.4.3, 16.5.3, 16.6.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.1 to before 16.4.3; 16.5 to before 16.5.3; 16.6 to before 16.6.1 Fixed in 16.4.3, 16.5.3, 16.6.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.1.0 to before 16.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.1.0 to before 16.4.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.5.0 to before 16.5.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.5.0 to before 16.5.3 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.6.0:*:*:*:community:*:*:* | 16.6.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.6.0:*:*:*:enterprise:*:*:* | 16.6.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.1.0 to before 16.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.1.0 to before 16.4.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.5.0 to before 16.5.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.5.0 to before 16.5.3 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.6.0:*:*:*:community:*:*:* Versions 16.6.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.6.0:*:*:*:enterprise:*:*:* Versions 16.6.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.4.3, 16.5.3, 16.6.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.4.3, 16.5.3, 16.6.1
9 records Highest priority Priority MEDIUM 2 MEDIUM, 7 LOW
Other records, highest priority first
- TI-2023-03670 Insertion of Sensitive Information Into Sent Data in GitLabPriority MEDIUM 63
- TI-2023-03681 Incorrect Authorization in GitLabPriority MEDIUM 53
- TI-2023-05556 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLabPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3443
- 2026-10-03 Alias added: GHSA-8fgm-gj9v-6jr5
References
Exploit 1
Advisory 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-3443 · CVE Program
- CVE-2023-3443 · NVD
- FIRST EPSS
- GHSA-8fgm-gj9v-6jr5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences