Read the docs
TI-2023-03273 Aliases CVE-2023-3507GHSA-wq2f-vmcc-p4fr

WooCommerce Pre-Orders < 2.0.3 - Arbitrary Pre-Order Canceling via CSRF

Priority MEDIUM 62Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WooCommerce Pre-Orders WordPress plugin before 2.0.3 has a flawed CSRF check when canceling pre-orders, which could allow attackers to make logged in admins cancel arbitrary pre-orders via a CSRF attack

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00307 23rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WooCommerce Pre-Orders (Unknown): 2.0.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWooCommerce Pre-Ordersbefore 2.0.32.0.3Patch availableCNA
  • WooCommerce Pre-Orders VendorUnknown Affected before 2.0.3 Fixed in 2.0.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:woocommerce:woocommerce_pre-orders:*:*:*:*:*:wordpress:*:*before 2.0.3VulnerableWooCommerce
  • cpe:2.3:a:woocommerce:woocommerce_pre-orders:*:*:*:*:*:wordpress:*:* Versions before 2.0.3 Vulnerable ·WooCommerce

Remediation

  • Fix · CNA WooCommerce Pre-Orders (Unknown) Fixed in 2.0.3

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    WooCommerce Pre-Orders 2.0.3

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2023-03274 WooCommerce Pre-Orders < 2.0.3 - Unauthorised Actions via CSRFPriority MEDIUM 62

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-3507
  2. 2026-10-03 Alias added: GHSA-wq2f-vmcc-p4fr

References

  • TI-2023-03274 WooCommerce Pre-Orders < 2.0.3 - Unauthorised Actions via CSRF CVSS 3.1MEDIUM 6.5
  • TI-2023-16054 WordPress WooCommerce Pre-Orders Plugin <= 1.9.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-16045 WordPress WooCommerce Pre-Orders Plugin <= 2.0.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources