Priority MEDIUM 62
The WooCommerce Pre-Orders WordPress plugin before 2.0.3 has a flawed CSRF check when processing its tab actions, which could allow attackers to make logged in admins email pre-orders customer, change the released date,…
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00307 · Published 2023-07-31 · Fixed in 2.0.3
Priority MEDIUM 62
The WooCommerce Pre-Orders WordPress plugin before 2.0.3 has a flawed CSRF check when canceling pre-orders, which could allow attackers to make logged in admins cancel arbitrary pre-orders via a CSRF attack
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00307 · Published 2023-07-31 · Fixed in 2.0.3
Priority MEDIUM 62
The WooCommerce Order Status Change Notifier WordPress plugin through 1.1.0 does not have authorisation and CSRF when updating status orders via an AJAX action available to any authenticated users, which could allow low…
CVSS 3.1MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.00337 · Published 2023-05-15 · No fix listed
Priority MEDIUM 53
The WooCommerce WordPress plugin before 6.2.1 does not have proper authorisation check when deleting reviews, which could allow any authenticated users, such as subscriber to delete arbitrary comment
CVSS 3.1MEDIUM 4.3· Network · Low privileges · No interaction · EPSS 0.00675 · Published 2024-01-16 · Fixed in 6.2.1 CWE-863
Priority MEDIUM 53
The WooCommerce Help Scout WordPress plugin before 2.9.1 (https://woocommerce.com/products/woocommerce-help-scout/) allows unauthenticated users to upload any files to the site which by default will end up in wp-content/…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.07908 · Published 2021-04-05 · Fixed in 2.9.1 CWE-434
Priority MEDIUM 50
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WooCommerce Product Vendors allows SQL Injection.This issue affects Product Vendors: from n/a through 2.1.78.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00732 · Published 2023-10-31 · No fix listed CWE-89
Priority MEDIUM 50
WooCommerce 7.1.0 contains a remote code execution vulnerability that allows attackers to execute arbitrary PHP code by injecting shell commands through the product-type parameter.
CVSS 4.0CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.01137 · Published 2026-06-20 · No fix listed CWE-94
Priority MEDIUM 50
woocommerce-gutenberg-products-block is a feature plugin for WooCommerce Gutenberg Blocks.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.17227 · Published 2021-07-26 · No fix listed CWE-89
Priority MEDIUM 49
Authorization Bypass Through User-Controlled Key vulnerability in WooCommerce WooCommerce Stripe Payment Gateway.This issue affects WooCommerce Stripe Payment Gateway: from n/a through 7.6.1.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00599 · Published 2024-01-05 · No fix listed CWE-639
Priority MEDIUM 49
Missing Authorization vulnerability in WooCommerce WooCommerce Stripe Payment Gateway.This issue affects WooCommerce Stripe Payment Gateway: from n/a through 7.4.0.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00614 · Published 2024-06-19 · No fix listed CWE-862
Priority MEDIUM 48
Missing Authorization vulnerability in Woo WooCommerce Product Vendors.This issue affects WooCommerce Product Vendors: from n/a through 2.2.1.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00365 · Published 2024-06-09 · No fix listed CWE-862
Priority MEDIUM 44
Unrestricted Upload of File with Dangerous Type vulnerability in WooCommerce AutomateWoo.This issue affects AutomateWoo: from n/a through 4.9.40.
CVSS 3.1CRITICAL 9.9· Network · Low privileges · No interaction · EPSS 0.00814 · Published 2023-12-20 · No fix listed CWE-434
Priority MEDIUM 42
The WooCommerce PayPal Payments plugin for WordPress is vulnerable to unauthorized order manipulation and information disclosure due to missing authorization checks on the `ppc-create-order` and `ppc-get-order` WC-AJAX e…
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.00462 · Published 2026-05-23 · No fix listed CWE-862
Priority MEDIUM 42
Ultimate WooCommerce Gift Cards 3.0.2 is affected by a file upload vulnerability in the Custom GiftCard Template that can remotely execute arbitrary code.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.02083 · Published 2020-12-28 · No fix listed CWE-434
Priority MEDIUM 42
In the Automattic WooCommerce plugin before 3.2.4 for WordPress, an attack is possible after gaining access to the target site with a user account that has at least Shop manager privileges.
CVSS 3.0HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01961 · Published 2019-01-15 · No fix listed CWE-94
Priority MEDIUM 41
Unauth. IDOR vulnerability leading to PII Disclosure in WooCommerce Stripe Payment Gateway plugin <= 7.4.0 versions.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01214 · Published 2023-06-14 · No fix listed CWE-639
Priority MEDIUM 40
Cross-Site Request Forgery (CSRF) vulnerability in WooCommerce Product Add-Ons plugin <= 6.1.3 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00301 · Published 2023-11-09 · No fix listed CWE-352
Priority MEDIUM 40
Cross-Site Request Forgery (CSRF) vulnerability in WooCommerce AutomateWoo plugin <= 5.7.1 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00301 · Published 2023-11-09 · No fix listed CWE-352
Priority MEDIUM 40
Cross-Site Request Forgery (CSRF) vulnerability in WooCommerce Product Recommendations plugin <= 2.3.0 versions.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00301 · Published 2023-11-09 · Fixed in 2.3.0 CWE-352
Priority LOW 39
The WooCommerce Square plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 5.1.1 via the get_token_by_id function due to missing validation on a user controlled ke…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00345 · Published 2026-01-10 · Fixed in 4.2.3, 4.3.2 +8 CWE-639
Priority LOW 39
Missing Authorization vulnerability in WooCommerce WooCommerce Box Office.This issue affects WooCommerce Box Office: from n/a through 1.2.2.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00504 · Published 2024-03-26 · No fix listed CWE-862
Priority LOW 39
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WooCommerce Product Vendors allows SQL Injection.This issue affects Product Vendors: from n/a through 2.1.76.
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.00929 · Published 2023-12-18 · No fix listed CWE-89
Priority LOW 39
Deserialization of Untrusted Data vulnerability in WooCommerce Product Add-Ons.This issue affects Product Add-Ons: from n/a through 6.1.3.
CVSS 3.1HIGH 8.2· Network · High privileges · No interaction · EPSS 0.00672 · Published 2023-12-28 · No fix listed CWE-502
Priority LOW 39
Authorization Bypass Through User-Controlled Key vulnerability in WooCommerce WooCommerce Bookings.This issue affects WooCommerce Bookings: from n/a through 1.15.78.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00449 · Published 2023-12-21 · No fix listed CWE-639
Priority LOW 39
WooCommerce before 3.6.5, when it handles CSV imports of products, has a cross-site request forgery (CSRF) issue with resultant stored cross-site scripting (XSS) via includes/admin/importers/class-wc-product-csv-importer…
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00534 · Published 2020-06-19 · Fixed in 3.6.5 CWE-352
Load more