Security issue with external entity loading in XML without enabling it
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and Red Hat.
Summary
In PHP versions 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* before 8.2.8 various XML functions rely on libxml global state to track configuration variables, like whether external entities are loaded. This state is assumed to be unchanged unless the user explicitly changes it by calling appropriate function. However, since the state is process-global, other modules - such as ImageMagick - may also use this library within the same process, and change that global state for their internal purposes, and leave it in a state where external entities loading is enabled. This can lead to the situation where external XML is parsed with external entities loaded, which can lead to disclosure of any local files accessible to PHP. This vulnerable state may persist in the same process across many requests, until the process is shut down.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHP Group | PHP | before 8.0.30; before 8.1.22; before 8.2.8 | 8.0.30, 8.1.22, 8.2.8 | Patch available | CNA |
- PHP VendorPHP Group Affected before 8.0.30; before 8.1.22; before 8.2.8 Fixed in 8.0.30, 8.1.22, 8.2.8 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:php:php:*:*:*:*:*:*:*:* | 8.0.0 to before 8.0.30; 8.1.0 to before 8.1.22; 8.2.0 to before 8.2.9 | Vulnerable | PHP |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:php:php:*:*:*:*:*:*:*:* Versions 8.0.0 to before 8.0.30; 8.1.0 to before 8.1.22; 8.2.0 to before 8.2.9 Vulnerable ·PHP
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA PHP (PHP Group) Fixed in 8.0.30, 8.1.22, 8.2.8
Red Hat 4 advisories
- RHSA-2024:10952 Released 2024-12-11 · Red Hat rating Moderatephp:7.4 security update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.18-1.module+el8.10.0+22485+a3539972.noarch::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.aarch64::php:7.4, libzip-1.6.1-1.module+el8.10.0+22485+a3539972.ppc64le::php:7.4 +47
- RHSA-2024:0387 Released 2024-01-24 · Red Hat rating Moderatephp:8.1 security update
- Red Hat Enterprise Linux AppStream (v. 9) apcu-panel-5.1.21-1.module+el9.1.0.z+15477+cb86791d.noarch::php:8.1, php-8.1.27-1.module+el9.3.0.z+21063+f4ccb976.aarch64::php:8.1, php-8.1.27-1.module+el9.3.0.z+21063+f4ccb976.ppc64le::php:8.1 +47
- RHSA-2023:5927 Released 2023-10-19 · Red Hat rating Importantphp:8.0 security update
- Red Hat Enterprise Linux AppStream (v. 8) apcu-panel-5.1.20-1.module+el8.6.0+13671+84712317.noarch::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.aarch64::php:8.0, libzip-1.7.3-1.module+el8.6.0+13671+84712317.ppc64le::php:8.0 +47
Show 1 more Red Hat advisories
- RHSA-2023:5926 Released 2023-10-19 · Red Hat rating Importantphp security update
- Red Hat Enterprise Linux AppStream (v. 9) php-8.0.30-1.el9_2, php-bcmath-8.0.30-1.el9_2, php-cli-8.0.30-1.el9_2 +22
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
PHP 8.0.30, 8.1.22, 8.2.8
2 records Highest priority Priority MEDIUM 2 MEDIUM
Other records, highest priority first
- TI-2023-03573 Buffer overflow and overread in phar_dir_read()Priority MEDIUM 62
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:5927, RHSA-2024:10952 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:5926, RHSA-2024:0387 |
Not affected: 3 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat OpenShift Dev Spaces
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3823
References
More PHP Group vulnerabilities
- TI-2024-04260 Argument Injection in PHP-CGI KEVCVSS 3.1CRITICAL 9.8
- TI-2026-78794 PHP remote code execution via stale global state KEVCVSS 4.0CRITICAL 9.2
- TI-2026-78793 Out-of-memory handling flaw in PHP allows remote code execution KEVCVSS 4.0CRITICAL 9.2
- TI-2024-01743 Command injection via array-ish $command parameter of proc_open() CVSS 3.1CRITICAL 9.4
- TI-2022-13555 PDO::quote() may return unquoted string CVSS 3.1CRITICAL 9.1
- TI-2024-10408 Reference counting in php_request_shutdown causes Use-After-Free CVSS 4.0CRITICAL 9.2
Sources
- CVE-2023-3823 · CVE Program
- CVE-2023-3823 · NVD
- FIRST EPSS
- CVE-2023-3823 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences