Modern Events Calendar lite < 7.1.0 - Authenticated (Admin+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Modern Events Calendar lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Google API key and Calendar ID in versions up to, but not including, 7.1.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA Modern Events Calendar Lite (webnus/) Fixed in 7.1.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4021
- 2026-10-03 Alias added: GHSA-mxc9-v9vg-4xfw
References
More Webnus Modern Events Calendar Lite vulnerabilities
- TI-2021-07225 Modern Events Calendar < 6.1.5 - Unauthenticated Blind SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2021-06437 Modern Events Calendar Lite < 5.16.5 - Authenticated Arbitrary File Upload leading to RCE CVSS 3.1HIGH 7.2
- TI-2022-00289 Modern Events Calendar Lite < 6.4.0 - Contributor+ Stored Cross Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2021-06438 Modern Events Calendar Lite < 5.16.5 - Unauthenticated Events Export CVSS 3.1HIGH 7.5
- TI-2023-01324 Modern Events Calendar lite < 6.5.2 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-05057 Modern Events Calendar <= 7.11.0 - Authenticated (Subscriber+) Arbitrary File Upload CVSS 3.1HIGH 8.8
Sources
- CVE-2023-4021 · CVE Program
- CVE-2023-4021 · NVD
- FIRST EPSS
- GHSA-mxc9-v9vg-4xfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences