Priority HIGH 80
The Modern Events Calendar Lite WordPress plugin before 6.1.5 does not sanitise and escape the time parameter before using it in a SQL statement in the mec_load_single_page AJAX action, available to unauthenticated users…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.728 · Published 2021-12-13 · Fixed in 6.1.5 CWE-89
Priority HIGH 74
Arbitrary file upload in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not properly check the imported file, allowing PHP ones to be uploaded by administrator by using the 'text/csv' conte…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.87201 · Published 2021-03-18 · Fixed in 5.16.5 CWE-434
Priority MEDIUM 62
The Modern Events Calendar Lite WordPress plugin before 6.4.0 does not sanitize and escape some of the Hourly Schedule parameters which could allow users with a role as low as contributor to perform Stored Cross-Site Scr…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.69552 · Published 2022-03-21 · Fixed in 6.4.0 CWE-79
Priority MEDIUM 57
Lack of authorisation checks in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not properly restrict access to the export files, allowing unauthenticated users to exports all events data in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.31043 · Published 2021-03-18 · Fixed in 5.16.5 CWE-284
Priority MEDIUM 55
The Modern Events Calendar Lite WordPress plugin before 6.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even wh…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00501 · Published 2023-03-27 · Fixed in 6.5.2.
Priority MEDIUM 46
Unauthenticated SQL Injection in Modern Events Calendar < 7.35.0 versions.
CVSS 3.1CRITICAL 9.3· Network · No auth · No interaction · EPSS 0.004 · Published 2026-08-18 · Fixed in 7.35.0 CWE-89
Priority MEDIUM 42
The Modern Events Calendar plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the set_featured_image function in all versions up to, and including, 7.11.0.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01117 · Published 2024-07-09 · No fix listed CWE-434
Priority MEDIUM 42
The Modern Events Calendar Lite plugin for WordPress is vulnerable to SQL Injection via the 'id' parameter of the 'wp_ajax_mec_load_single_page' AJAX action in all versions up to, and including, 6.3.0 due to insufficient…
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.004 · Published 2025-07-12 · No fix listed CWE-89
Priority MEDIUM 41
The Modern Events Calendar plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 7.12.1 via the 'mec_fes_form' AJAX function.
CVSS 3.1CRITICAL 9.6· Network · Low privileges · No interaction · EPSS 0.00405 · Published 2024-08-07 · No fix listed CWE-918
Priority MEDIUM 41
Unvalidated input in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.6, did not sanitise the mec[post_id] POST parameter in the mec_fes_form AJAX action when logged in as an author+, leading to an…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01505 · Published 2021-03-18 · Fixed in 5.16.6 CWE-89
Priority LOW 36
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Webnus Modern Events Calendar Lite modern-events-calendar-lite allows Blind SQL Injection.This issue affects Modern Ev…
CVSS 3.1HIGH 8.5· Network · Low privileges · No interaction · EPSS 0.0027 · Published 2026-10-14 · Fixed in 7.37.0 CWE-89
Priority LOW 30
The Modern Events Calendar Lite plugin for WordPress is vulnerable to Full Path Disclosure in all versions up to, and including, 7.21.9.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00356 · Published 2025-06-06 · No fix listed CWE-201
Priority LOW 29
The Modern Events Calendar Lite WordPress plugin before 6.1.5 does not sanitise and escape the current_month_divider parameter of its mec_list_load_more AJAX call (available to both unauthenticated and authenticated user…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00822 · Published 2021-12-13 · Fixed in 6.1.5 CWE-79
Priority LOW 26
Unvalidated input and lack of output encoding in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not sanitise the mic_comment field (Notes on time) when adding/editing an event, allowing use…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00748 · Published 2021-03-18 · Fixed in 5.16.5 CWE-79
Priority LOW 26
Multiple Stored Cross-site scripting (XSS) vulnerabilities in the Webnus Modern Events Calendar Lite plugin through 5.1.6 for WordPress allows remote authenticated users (with minimal permissions) to inject arbitrary Jav…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01024 · Published 2020-02-28 · No fix listed CWE-79
Priority LOW 25
Missing Authorization vulnerability in Webnus Inc.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00715 · Published 2026-03-16 · No fix listed CWE-862
Priority LOW 25
Cross-site scripting vulnerability in Modern Events Calendar Lite versions prior to 6.3.0 allows remote an authenticated attacker to inject an arbitrary script via unspecified vectors.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00573 · Published 2022-06-16 · Fixed in 6.3.0 CWE-79
Priority LOW 25
The Modern Events Calendar Lite WordPress plugin before 6.2.0 alloed any logged-in user, even a subscriber user, may add a category whose parameters are incorrectly escaped in the admin panel, leading to stored XSS.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00611 · Published 2022-01-17 · Fixed in 6.2.0 CWE-79
Priority LOW 25
The Modern Events Calendar Lite WordPress plugin before 5.22.3 does not properly sanitize or escape values set by users with access to adjust settings withing wp-admin.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.0065 · Published 2021-11-01 · Fixed in 5.22.3 CWE-79
Priority LOW 23
Authenticated (admin+ user) Stored Cross-Site Scripting (XSS) in Modern Events Calendar Lite (WordPress plugin) <= 6.5.1
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00565 · Published 2022-04-14 · No fix listed CWE-79
Priority LOW 23
The Modern Events Calendar Lite WordPress plugin before 5.22.2 does not escape some of its settings before outputting them in attributes, allowing high privilege users to perform Cross-Site Scripting attacks even when th…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00617 · Published 2021-10-04 · Fixed in 5.22.2 CWE-79
Priority LOW 22
The Modern Events Calendar lite plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Google API key and Calendar ID in versions up to, but not including, 7.1.0 due to insufficient input sanitization and…
CVSS 3.1MEDIUM 4.8· Network · High privileges · User interaction · EPSS 0.00378 · Published 2023-10-20 · Fixed in 7.1.0 CWE-79