Simple Blog Card < 1.31 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Simple Blog Card WordPress plugin before 1.31 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00433 37th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Simple Blog Card (Unknown): 1.31
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Blog Card | before 1.31 | 1.31 | Patch available | CNA |
- Simple Blog Card VendorUnknown Affected before 1.31 Fixed in 1.31 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:riverforest-wp:simple_blog_card:*:*:*:*:*:wordpress:*:* | before 1.31 | Vulnerable | Riverforest-wp |
- cpe:2.3:a:riverforest-wp:simple_blog_card:*:*:*:*:*:wordpress:*:* Versions before 1.31 Vulnerable ·Riverforest-wp
Remediation
- Fix · CNA Simple Blog Card (Unknown) Fixed in 1.31
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4035
- 2026-10-03 Alias added: GHSA-8hw5-9v34-vmg4
References
More Riverforest-wp Simple Blog Card vulnerabilities
- TI-2023-03745 Simple Blog Card < 1.32 - Subscriber+ Arbitrary Post Access CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-4035 · CVE Program
- CVE-2023-4035 · NVD
- FIRST EPSS
- GHSA-8hw5-9v34-vmg4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences