Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in Crafter Engine
Priority LOW 35CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in CrafterCMS Engine on Windows, MacOS, Linux, x86, ARM, 64 bit allows Reflected XSS.This issue affects CrafterCMS: from 4.0.0 through 4.0.2, from 3.1.0 through 3.1.27.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0142 72nd percentileScored 2026-11-07
Fix Fixed org.craftercms:crafter-engine (Maven): 4.0.3, 3.1.28
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Crafter Software | CrafterCMS | 4.0.0 – 4.0.2; 3.1.0 – 3.1.27 | — | No fix listed | CNA |
| — | org.craftercms:crafter-engine (Maven) | 4.0.0 to before 4.0.3 | 4.0.3 | Patch available | GHSA-jfm4-3vv3-fm4v |
| — | org.craftercms:crafter-engine (Maven) | 3.1.0 to before 3.1.28 | 3.1.28 | Patch available | GHSA-jfm4-3vv3-fm4v |
- CrafterCMS VendorCrafter Software Affected 4.0.0 – 4.0.2; 3.1.0 – 3.1.27 Fixed in — No fix listed CNA
- org.craftercms:crafter-engine (Maven) Vendor— Affected 4.0.0 to before 4.0.3 Fixed in 4.0.3 Patch available GHSA-jfm4-3vv3-fm4v
- org.craftercms:crafter-engine (Maven) Vendor— Affected 3.1.0 to before 3.1.28 Fixed in 3.1.28 Patch available GHSA-jfm4-3vv3-fm4v
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftercms:craftercms:*:*:*:*:*:*:*:* | 3.1.0 – 3.1.27; 4.0.0 – 4.0.2 | Vulnerable | Crafter Software |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:arm:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:x64:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:apple:macos:-:*:*:*:*:*:x86:* | not specified by NVD | Running on | Apple |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:arm:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:x64:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:x86:* | not specified by NVD | Running on | Linux |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:arm:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:x64:* | not specified by NVD | Running on | Microsoft |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:x86:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:craftercms:craftercms:*:*:*:*:*:*:*:* Versions 3.1.0 – 3.1.27; 4.0.0 – 4.0.2 Vulnerable ·Crafter Software
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:arm:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:x64:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:apple:macos:-:*:*:*:*:*:x86:* Versions not specified by NVD Running on ·Apple
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:arm:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:x64:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:linux:linux_kernel:-:*:*:*:*:*:x86:* Versions not specified by NVD Running on ·Linux
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:arm:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:x64:* Versions not specified by NVD Running on ·Microsoft
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:x86:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · GHSA-jfm4-3vv3-fm4v org.craftercms:crafter-engine (Maven) Fixed in 4.0.3 Advisory →
- Fix · GHSA-jfm4-3vv3-fm4v org.craftercms:crafter-engine (Maven) Fixed in 3.1.28 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4136
- 2026-10-03 Alias added: GHSA-jfm4-3vv3-fm4v
References
Advisory 2
More Crafter Software Craftercms vulnerabilities
- TI-2023-16371 CraftCMS stored XSS in Quick Post widget error message CVSS 3.1MEDIUM 4.8
- TI-2025-00416 Transmission of Private Resources into a New Sphere in Crafter Engine CVSS 4.0MEDIUM 6.9
- TI-2025-05785 Improper Control of Dynamically-Managed Code Resources in Crafter Studio CVSS 4.0HIGH 7.3
Sources
- CVE-2023-4136 · CVE Program
- CVE-2023-4136 · NVD
- FIRST EPSS
- GHSA-jfm4-3vv3-fm4v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences