CraftCMS stored XSS in Quick Post widget error message
Priority MEDIUM 55CWE-80Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-80.
Summary
Craft is a CMS for creating custom digital experiences on the web.The platform does not filter input and encode output in Quick Post validation error message, which can deliver an XSS payload. Old CVE fixed the XSS in label HTML but didn’t fix it when clicking save. This issue was patched in version 4.4.6.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed cms (craftcms): 4.4.6craftcms/cms (Packagist): 4.4.6, 3.8.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Craft CMS | cms | 4.0.0-RC1 to before 4.4.6; 3.0.0 – 3.8.5 | 4.4.6 | Patch available | CNA |
| — | craftcms/cms (Packagist) | 4.0.0-RC1 to before 4.4.6 | 4.4.6 | Patch available | GHSA-3wxg-w96j-8hq9 |
| — | craftcms/cms (Packagist) | 3.0.0 to before 3.8.6 | 3.8.6 | Patch available | GHSA-3wxg-w96j-8hq9 |
- cms VendorCraft CMS Affected 4.0.0-RC1 to before 4.4.6; 3.0.0 – 3.8.5 Fixed in 4.4.6 Patch available CNA
- craftcms/cms (Packagist) Vendor— Affected 4.0.0-RC1 to before 4.4.6 Fixed in 4.4.6 Patch available GHSA-3wxg-w96j-8hq9
- craftcms/cms (Packagist) Vendor— Affected 3.0.0 to before 3.8.6 Fixed in 3.8.6 Patch available GHSA-3wxg-w96j-8hq9
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* | 3.0.0 to before 3.8.6; 4.0.1 to before 4.4.6 | Vulnerable | Craft CMS |
| cpe:2.3:a:craftercms:craftercms:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Crafter Software |
| cpe:2.3:a:craftercms:craftercms:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Crafter Software |
| cpe:2.3:a:craftercms:craftercms:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Crafter Software |
| cpe:2.3:a:craftercms:craftercms:4.0.0:rc3:*:*:*:*:*:* | 4.0.0 rc3 | Vulnerable | Crafter Software |
- cpe:2.3:a:craftcms:craft_cms:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.8.6; 4.0.1 to before 4.4.6 Vulnerable ·Craft CMS
- cpe:2.3:a:craftercms:craftercms:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Crafter Software
- cpe:2.3:a:craftercms:craftercms:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Crafter Software
- cpe:2.3:a:craftercms:craftercms:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Crafter Software
- cpe:2.3:a:craftercms:craftercms:4.0.0:rc3:*:*:*:*:*:* Versions 4.0.0 rc3 Vulnerable ·Crafter Software
Remediation
- Fix · CNA cms (craftcms) Fixed in 4.4.6
- Fix · GHSA-3wxg-w96j-8hq9 craftcms/cms (Packagist) Fixed in 4.4.6 Advisory →
- Fix · GHSA-3wxg-w96j-8hq9 craftcms/cms (Packagist) Fixed in 3.8.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-33194
- 2026-10-03 Alias added: GHSA-3wxg-w96j-8hq9
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-33194 · CVE Program
- CVE-2023-33194 · NVD
- FIRST EPSS
- GHSA-3wxg-w96j-8hq9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences