POEditor < 0.9.8 - Settings Reset via CSRF
Priority MEDIUM 53Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The POEditor WordPress plugin before 0.9.8 does not have CSRF checks in various places, which could allow attackers to make logged in admins perform unwanted actions, such as reset the plugin's settings and update its API key via CSRF attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00252 16th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed POEditor (Unknown): 0.9.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | POEditor | before 0.9.8 | 0.9.8 | Patch available | CNA |
- POEditor VendorUnknown Affected before 0.9.8 Fixed in 0.9.8 Patch available CNA
Remediation
- Fix · CNA POEditor (Unknown) Fixed in 0.9.8
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4209
- 2026-10-03 Alias added: GHSA-7mhg-9f7m-6g74
References
More Poeditor vulnerabilities
- TI-2023-15394 WordPress POEditor Plugin <= 0.9.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-21348 WordPress POEditor plugin <= 0.9.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-4209 · CVE Program
- CVE-2023-4209 · NVD
- FIRST EPSS
- GHSA-7mhg-9f7m-6g74 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences