Read the docs
TI-2023-04698 Aliases CVE-2023-5109GHSA-fq8c-93h2-hrr9

Cross-site scripting in onlineoptimisation WP Mailto Links – Protect Email Addresses

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Mailto Links – Protect Email Addresses plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'wpml_mailto' shortcode in versions up to, and including, 3.1.3 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 3.1.3 and fully patched in version 3.1.4.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00485 42nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
onlineoptimisationWP Mailto Links – Protect Email Addressesup to 3.1.3—No fix listedCNA
  • WP Mailto Links – Protect Email Addresses Vendoronlineoptimisation Affected up to 3.1.3 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ironikus:wp_mailto_links:*:*:*:*:*:wordpress:*:*before 3.1.4VulnerableIronikus
  • cpe:2.3:a:ironikus:wp_mailto_links:*:*:*:*:*:wordpress:*:* Versions before 3.1.4 Vulnerable ·Ironikus

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5109
  2. 2026-10-03 Alias added: GHSA-fq8c-93h2-hrr9

References

  • TI-2024-01192 Cross-site scripting in onlineoptimisation Email Encoder – Protect Email Addresses and… CVSS 3.1MEDIUM 6.4
  • TI-2023-25929 WordPress Email Encoder Bundle Plugin <= 2.1.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2023-06466 Cross-site scripting in onlineoptimisation Email Encoder – Protect Email Addresses and… CVSS 3.1MEDIUM 6.4
  • TI-2023-04243 Email Encoder <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
  • TI-2026-02439 Cross-site scripting in onlineoptimisation Email Encoder – Protect Email Addresses and… CVSS 3.1MEDIUM 6.4
  • TI-2025-33409 WordPress WP Mailto Links Plugin <= 3.1.4 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 5.9

Sources