Email Encoder <= 2.1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Email Encoder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'eeb_mailto' shortcode in versions up to, and including, 2.1.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A partial patch was issued in version 2.1.8. The vulnerability was fully patched in 2.1.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| onlineoptimisation | Email Encoder – Protect Email Addresses and Phone Numbers | up to 2.1.8 | — | No fix listed | CNA |
- Email Encoder – Protect Email Addresses and Phone Numbers Vendoronlineoptimisation Affected up to 2.1.8 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp-webhooks:email_encoder:*:*:*:*:*:wordpress:*:* | up to 2.1.7 | Vulnerable | Wp-webhooks |
- cpe:2.3:a:wp-webhooks:email_encoder:*:*:*:*:*:wordpress:*:* Versions up to 2.1.7 Vulnerable ·Wp-webhooks
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4599
- 2026-10-03 Alias added: GHSA-76p2-85pf-cqf5
References
Other 3
- https://plugins.trac.wordpress.org/browser/email-encoder-bundle/tags/2.1.7/core/includes/classes/class-email-encoder-bundle-run.php#L529
- https://plugins.trac.wordpress.org/changeset/2958823/email-encoder-bundle#file60
- https://plugins.trac.wordpress.org/changeset/2994384/email-encoder-bundle/trunk?contextall=1&old=2958823&old_path=%2Femail-encoder-bundle%2Ftrunk#file0
More onlineoptimisation vulnerabilities
- TI-2024-01192 Cross-site scripting in onlineoptimisation Email Encoder – Protect Email Addresses and… CVSS 3.1MEDIUM 6.4
- TI-2023-25929 WordPress Email Encoder Bundle Plugin <= 2.1.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-06466 Cross-site scripting in onlineoptimisation Email Encoder – Protect Email Addresses and… CVSS 3.1MEDIUM 6.4
- TI-2023-04698 Cross-site scripting in onlineoptimisation WP Mailto Links – Protect Email Addresses CVSS 3.1MEDIUM 6.4
- TI-2026-02439 Cross-site scripting in onlineoptimisation Email Encoder – Protect Email Addresses and… CVSS 3.1MEDIUM 6.4
- TI-2025-33409 WordPress WP Mailto Links Plugin <= 3.1.4 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-4599 · CVE Program
- CVE-2023-4599 · NVD
- FIRST EPSS
- GHSA-76p2-85pf-cqf5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences