Cross-site Scripting (XSS) - Reflected in microweber/microweber
Priority MEDIUM 60CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - Reflected in GitHub repository microweber/microweber prior to 2.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01122 66th percentileScored 2026-11-07
Fix Fixed microweber/microweber (microweber): 2.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| microweber | microweber/microweber | before 2.0 | 2.0 | Patch available | CNA |
| — | microweber/microweber (Packagist) | up to 1.3.4 | — | No fix listed | GHSA-rgf9-j7gv-rq22 |
- microweber/microweber Vendormicroweber Affected before 2.0 Fixed in 2.0 Patch available CNA
- microweber/microweber (Packagist) Vendor— Affected up to 1.3.4 Fixed in — No fix listed GHSA-rgf9-j7gv-rq22
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* | before 2.0 | Vulnerable | microweber |
- cpe:2.3:a:microweber:microweber:*:*:*:*:*:*:*:* Versions before 2.0 Vulnerable ·microweber
Remediation
- Fix · CNA microweber/microweber (microweber) Fixed in 2.0
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5244
- 2026-10-03 Alias added: GHSA-rgf9-j7gv-rq22
References
More Microweber vulnerabilities
- TI-2023-01763 Command Injection in microweber/microweber CVSS 3.1CRITICAL 9.8
- TI-2023-02100 Improper Privilege Management in microweber/microweber CVSS 3.1HIGH 8.8
- TI-2022-14518 Microweber v1.2.15 was discovered to allow attackers to perform an account takeover via a host header injection attack. CVSS 3.1HIGH 8.8
- TI-2023-04891 Use of Hard-coded Credentials in microweber/microweber CVSS 3.1HIGH 7.5
- TI-2025-37870 Microweber CMS 2.0 has Weak Password Requirements. CVSS 3.1HIGH 8.3
- TI-2022-04247 Cross-site Scripting (XSS) - Stored in microweber/microweber CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-5244 · CVE Program
- CVE-2023-5244 · NVD
- FIRST EPSS
- GHSA-rgf9-j7gv-rq22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences