Broken Session Management in Puppet Enterprise
Priority MEDIUM 43CWE-384Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-384.
Summary
Versions of Puppet Enterprise prior to 2021.7.6 and 2023.5 contain a flaw which results in broken session management for SAML implementations.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00496 42nd percentileScored 2026-11-07
Fix Fixed Puppet Enterprise (Puppet): 2021.7.6, 2023.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Puppet | Puppet Enterprise | 2021.7.0 to before 2021.7.6; 2023.0.0 to before 2023.5 | 2021.7.6, 2023.5 | Patch available | CNA |
- Puppet Enterprise VendorPuppet Affected 2021.7.0 to before 2021.7.6; 2023.0.0 to before 2023.5 Fixed in 2021.7.6, 2023.5 Patch available CNA
Remediation
- Fix · CNA Puppet Enterprise (Puppet) Fixed in 2021.7.6, 2023.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5309
- 2026-10-03 Alias added: GHSA-c7r6-m4rr-fqqm
References
More Puppet Enterprise vulnerabilities
- TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
- TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
- TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
- TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-5309 · CVE Program
- CVE-2023-5309 · NVD
- FIRST EPSS
- GHSA-c7r6-m4rr-fqqm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences