Read the docs
TI-2023-05098 Aliases CVE-2023-5540GHSA-w8x2-w4qr-v3x4

Moodle: authenticated remote code execution risk in imscp

Priority MEDIUM 44CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

A remote code execution risk was identified in the IMSCP activity. By default this was only available to teachers and managers.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.02269 83rd percentileScored 2026-11-07
Fix Fixed moodle: 4.2.3, 4.1.6, 4.0.11 +2moodle/moodle (Packagist): 4.3.0-rc2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.244.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24Patch availableCNA
—moodle/moodle (Packagist)before 4.3.0-rc24.3.0-rc2Patch availableGHSA-w8x2-w4qr-v3x4
  • moodle Vendor— Affected 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.3.0-rc2 Fixed in 4.3.0-rc2 Patch available GHSA-w8x2-w4qr-v3x4

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3VulnerableMoodle
cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:*7.0VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*38VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 Vulnerable ·Moodle
  • cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject

Remediation

  • Fix · CNA moodle Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24
  • Fix · GHSA-w8x2-w4qr-v3x4 moodle/moodle (Packagist) Fixed in 4.3.0-rc2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5540
  2. 2026-10-03 Alias added: GHSA-w8x2-w4qr-v3x4

References

Sources