Moodle: stored xss and potential idor risk in wiki comments
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting, Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79 and CWE-639.
Summary
Wiki comments required additional sanitizing and access restrictions to prevent a stored XSS risk and potential IDOR risk.
Why it matters now
EPSS 0.00602 49th percentileScored 2026-11-07
Fix Fixed moodle: 4.2.3, 4.1.6, 4.0.11 +2moodle/moodle (Packagist): 4.3.0-rc2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 | 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.3.0-rc2 | 4.3.0-rc2 | Patch available | GHSA-j5xf-gv89-g422 |
- moodle Vendor— Affected 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.3.0-rc2 Fixed in 4.3.0-rc2 Patch available GHSA-j5xf-gv89-g422
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 | Vulnerable | Moodle |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 Vulnerable ·Moodle
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA moodle Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24
- Fix · GHSA-j5xf-gv89-g422 moodle/moodle (Packagist) Fixed in 4.3.0-rc2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5544
- 2026-10-03 Alias added: GHSA-j5xf-gv89-g422
References
Patch 2
Sources
- CVE-2023-5544 · CVE Program
- CVE-2023-5544 · NVD
- FIRST EPSS
- GHSA-j5xf-gv89-g422 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5544 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences