Moodle: xss risk when previewing data in course upload tool
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The course upload preview contained an XSS risk for users uploading unsafe data.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00535 45th percentileScored 2026-11-07
Fix Fixed moodle: 4.2.3, 4.1.6, 4.0.11 +2moodle/moodle (Packagist): 4.3.0-rc2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | moodle | 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 | 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 | Patch available | CNA |
| — | moodle/moodle (Packagist) | before 4.3.0-rc2 | 4.3.0-rc2 | Patch available | GHSA-9gqp-3g28-w9xc |
- moodle Vendor— Affected 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 Patch available CNA
- moodle/moodle (Packagist) Vendor— Affected before 4.3.0-rc2 Fixed in 4.3.0-rc2 Patch available GHSA-9gqp-3g28-w9xc
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.9.0 to before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 | Vulnerable | Moodle |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.9.0 to before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 Vulnerable ·Moodle
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA moodle Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24
- Fix · GHSA-9gqp-3g28-w9xc moodle/moodle (Packagist) Fixed in 4.3.0-rc2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5547
- 2026-10-03 Alias added: GHSA-9gqp-3g28-w9xc
References
Patch 2
Sources
- CVE-2023-5547 · CVE Program
- CVE-2023-5547 · NVD
- FIRST EPSS
- GHSA-9gqp-3g28-w9xc · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5547 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences