Read the docs
TI-2023-05107 Aliases CVE-2023-5549GHSA-fm5h-58g2-4m3f

Moodle: insufficient capability checks when updating the parent of a course category

Priority LOW 25CWE-284Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass, Privilege escalation
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284 and CWE-269.

Summary

Insufficient web service capability checks made it possible to move categories a user had permission to manage, to a parent category they did not have the capability to manage.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00592 48th percentileScored 2026-11-07
Fix Fixed moodle: 4.2.3, 4.1.6, 4.0.11 +2moodle/moodle (Packagist): 4.3.0-rc2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—moodle4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.244.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24Patch availableCNA
—moodle/moodle (Packagist)before 4.3.0-rc24.3.0-rc2Patch availableGHSA-fm5h-58g2-4m3f
  • moodle Vendor— Affected 4.2.0 to before 4.2.3; 4.1.0 to before 4.1.6; 4.0.0 to before 4.0.11; 3.11.0 to before 3.11.17; before 3.9.24 Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected before 4.3.0-rc2 Fixed in 4.3.0-rc2 Patch available GHSA-fm5h-58g2-4m3f

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3VulnerableMoodle
cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:*7.0VulnerableFedoraproject
cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:*38VulnerableFedoraproject
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions before 3.9.24; 3.11.0 to before 3.11.17; 4.0.0 to before 4.0.11; 4.1.0 to before 4.1.6; 4.2.0 to before 4.2.3 Vulnerable ·Moodle
  • cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Fedoraproject
  • cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject

Remediation

  • Fix · CNA moodle Fixed in 4.2.3, 4.1.6, 4.0.11, 3.11.17, 3.9.24
  • Fix · GHSA-fm5h-58g2-4m3f moodle/moodle (Packagist) Fixed in 4.3.0-rc2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5549
  2. 2026-10-03 Alias added: GHSA-fm5h-58g2-4m3f

References

Sources