Authentication bypass by spoofing in Canonical Ubuntu's gnome-control-center
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and Red Hat. Impact type from CWE-290.
Summary
In Ubuntu, gnome-control-center did not properly reflect SSH remote login status when the system was configured to use systemd socket activation for openssh-server. This could unknowingly leave the local machine exposed to remote SSH access contrary to expectation of the user.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Canonical | Ubuntu's gnome-control-center | 1:45 to before 1:45.0-1ubuntu3.1; 1:44 to before 1:44.0-1ubuntu6.1; 1:41 to before 1:41.7-0ubuntu0.22.04.8; 1:3 to before 1:3.36.5-0ubuntu4.1 | 1:45.0-1ubuntu3.1, 1:44.0-1ubuntu6.1, 1:41.7-0ubuntu0.22.04.8, 1:3.36.5-0ubuntu4.1 | Patch available | CNA |
- Ubuntu's gnome-control-center VendorCanonical Affected 1:45 to before 1:45.0-1ubuntu3.1; 1:44 to before 1:44.0-1ubuntu6.1; 1:41 to before 1:41.7-0ubuntu0.22.04.8; 1:3 to before 1:3.36.5-0ubuntu4.1 Fixed in 1:45.0-1ubuntu3.1, 1:44.0-1ubuntu6.1, 1:41.7-0ubuntu0.22.04.8, 1:3.36.5-0ubuntu4.1 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnome:control_center:*:*:*:*:*:*:*:* | 1.3 to before 1.3.36.5-0ubuntu4.1; 1.41 to before 1.41.7-0ubuntu0.22.04.8; 1.44 to before 1.44.0-1ubuntu6.1; 1.45 to before 1.45.0-1ubuntu3.1 | Vulnerable | GNOME |
| cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* | 20.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:22.04:*:*:*:lts:*:*:* | 22.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:23.04:*:*:*:*:*:*:* | 23.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:23.10:*:*:*:*:*:*:* | 23.10 | Vulnerable | Canonical |
- cpe:2.3:a:gnome:control_center:*:*:*:*:*:*:*:* Versions 1.3 to before 1.3.36.5-0ubuntu4.1; 1.41 to before 1.41.7-0ubuntu0.22.04.8; 1.44 to before 1.44.0-1ubuntu6.1; 1.45 to before 1.45.0-1ubuntu3.1 Vulnerable ·GNOME
- cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:22.04:*:*:*:lts:*:*:* Versions 22.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:23.04:*:*:*:*:*:*:* Versions 23.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:23.10:*:*:*:*:*:*:* Versions 23.10 Vulnerable ·Canonical
Remediation
- Fix · CNA Ubuntu's gnome-control-center (Canonical Ltd.) Fixed in 1:45.0-1ubuntu3.1, 1:44.0-1ubuntu6.1, 1:41.7-0ubuntu0.22.04.8, 1:3.36.5-0ubuntu4.1
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 8 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5616
- 2026-10-03 Alias added: GHSA-78gq-q74g-w632
References
More Canonical Ubuntu Linux vulnerabilities
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
- TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2023-5616 · CVE Program
- CVE-2023-5616 · NVD
- FIRST EPSS
- GHSA-78gq-q74g-w632 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5616 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences